The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.
Problem
You cannot view a non-Hexagon file, and the Brava! Enterprise log file indicates that the Brava! Enterprise license server cannot be contacted. For example, the log file might contain a message similar to:
2018-04-16T20:40:38,702+0000 [Publishing.SubmissionWorker-7]
ERROR c.i.b.c.f.FsPublishRequestHandler - Cannot contact a HTTP License Server
com.infograph.A.A: Cannot contact a HTTP License Server
Cause
The Brava! Enterprise license web application was installed, but not deployed.
Solution
The Brava! Enterprise license web application is deployed by Apache Tomcat. To deploy the application, restart the Tomcat service so that the BravaLicense folder appears in the Tomcat webapps directory (for example, Tomcat\webapps\BravaLicense).