The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.
Problem
The Apache Tomcat service fails to start.
Cause
You might encounter this problem if:
-
The specified paths on the General and Java tabs on the Apache Tomcat Properties dialog box are incorrect.
-
The JRE_HOME variable is not pointing to the right Java Runtime Environment location.
Solutions
Check the specified paths for Apache Tomcat:
-
Log on to the SmartPlant Markup Plus server as an administrator.
-
Click Start > Apache Tomcat [version] > Configure Tomcat.
-
Select the General tab and make sure the paths are correct.
-
Select the Java tab and make sure the paths are correct.
Check the JRE_HOME variable:
-
Log on to the SmartPlant Markup Plus server as an administrator.
-
Click Start > Control Panel > System > Advanced system settings.
-
On the Advanced tab, click Environment Variables.
-
Make sure the JRE_HOME variable is set to the correct path to Java Runtime Environment.
If this variable does not exist, click New to create one.