Unable to load error (retired) - SmartPlant Foundation - SmartPlant Foundation 2020 - Help - Hexagon

SmartPlant Foundation and Web Client Modified and Retired Functionality

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SmartPlant Markup Plus Version
10.0 (2019)

The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.

Error

When viewing a non-Hexagon file in the View and Markup page, an "unable to load" error displays.

Common Cause

You might encounter this problem if SSL certificates were not imported properly.

Solution

Make sure all SSL certificates, including intermediate certificates, are imported to:

  • Local Computer > Personal and Local Computer > Trusted Root Certification Authorities in IIS Manager on the SmartPlant Foundation application server, SmartPlant Markup Plus server, and SmartPlant Foundation File Server (if separate from the application server)

  • The local keystore on the SmartPlant Markup Plus server, using Java Keytool. For help, see the Apache Tomcat documentation at tomcat.apache.org.