The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.
Problem
Content is missing from a Microsoft Office file format using the View and Markup page.
Common Cause
You might encounter this problem if the wrong publishing method is enabled in the BIPrint.ini file.
Solution
Two INI settings specify how Microsoft Office file formats are published: [SaveAsXPS] and [SaveAsPDF]. Which setting is enabled by default depends on which version of SmartPlant Markup Plus Server is installed. For versions 2019 Service Pack 1 and later, [SaveAsPDF] is the default. For versions prior to 2019 Service Pack 1, [SaveAsXPS] is the default. You can change which method is used by following these steps:
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Go to [installation location]\Brava! Enterprise\CSFWriter and open the BIPrint.ini file.
If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the folder is: [installation location]\SmartPlant\Markup\Blazon\Blazon Enterprise\CSFWriter.
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Add the file extension to the setting you want to enable, [SaveAsXPS] or [SaveAsPDF].
If the file extension is added to both settings, [SaveAsXPS] will be used.
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Remove the file extension from the setting you want to disable, [SaveAsXPS] or [SaveAsPDF].
If you want to exclude all file types from a specific application, add a semicolon (;) to the beginning of the line. For example:
;Excel=xls, xlsx, xlsm, xltx
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Save your changes.