The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.
Error
When attempting to view a non-Hexagon file in the View and Markup page, the following errors appear:
HTML Client is ready.
The client encountered a problem with the previous view request.
For more detailed information please review the JavaScript console.
Starting ...
Common Causes
You might encounter these errors if the:
-
IGC Brava! Enterprise License Server service is not running.
-
Brava! Enterprise license has expired.
-
IP address of the application server is not authorized.
-
JRE_HOME variable is improperly set.
-
Java Development Kit is installed.
-
SSL certificates are not imported properly.
-
Connector attributes are not set properly.
Solutions