Cannot view a PDF file with a BPN or MSG file attached (retired) - SmartPlant Foundation - SmartPlant Foundation 2020 - Help - Hexagon

SmartPlant Foundation and Web Client Modified and Retired Functionality

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English
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SmartPlant Foundation
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SmartPlant Foundation / SDx Version
10
SmartPlant Markup Plus Version
10.0 (2019)

The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.

Problem

You cannot view a PDF file with a BPN or MSG file attached using the View and Markup page.

Common Cause

File viewing fails because BPN and MSG file types are not supported.

Solution

Use the Loader Configuration Tool to exclude the BPN and/or MSG files.

  1. Log on to the SmartPlant Markup server as an administrator.

  2. Go to this folder:

    [installation location]\SmartPlant\Markup\Brava! Enterprise\JobProcessor\Igc.Loaders

    If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the folder is: [installation location]\SmartPlant\Markup\Blazon\Blazon Enterprise\JobProcessor\Igc.Loaders.

  3. Run loaders.configuration.exe.

  4. Expand Pdf2dl - Adobe PDF Loader > Parameters.

  5. Select IgnoreAttachmentsWithExt, and click Change Value.

  6. In the Edit Parameter dialog box, click Add New.

  7. Add the .bpn and/or .msg file extensions to the list. Click OK when you are done.

  8. Click Done, then Yes to confirm changes.

  9. Go to Start > Administrative Tools > Services and restart these services in the following order:

    1. Apache Tomcat

    2. Brava! Job Processor

      If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the job processor service is called Blazon Job Processor.

    3. Blazon Queue Server

  10. Delete the files in the Brava! Server dlcache folder. This prevents illegible copies cached prior to the changes from being displayed.

    SHARED Tip You can click Clear Display Cache on the Actions menu of the file or document in the Web Client.

  11. Open the file in the Web Client.

SHARED Tip For more information on using the Loader Configuration Tool, see the Loader Configuration Tool Guide. It is delivered to the following folder on the SmartPlant Markup server: [installation location]\SmartPlant\Markup\Brava! Enterprise\JobProcessor\Igc.Loaders. If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, it is delivered to: [installation location]\SmartPlant\Markup\Blazon\Blazon Enterprise\JobProcessor\Igc.Loaders.