The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.
Problem
A 2D DWG file displays text with an incorrect font when displayed using View and Markup.
Common Cause
The font file is missing or corrupt.
Solution
Using the Loader Configuration Tool, you can enable the TruType font in the absence of custom CAD fonts.
-
Log on to the SmartPlant Markup Plus server as an administrator.
-
Go to this folder:
[installation location]\SmartPlant\Markup\Brava! Enterprise\JobProcessor\Igc.Loaders
If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the folder is: [installation location]\SmartPlant\Markup\Blazon\Blazon Enterprise\JobProcessor\Igc.Loaders.
-
Run loaders.configuration.exe.
-
Expand Dwg2dl - AutoCAD 2D Drawing Loader > Parameters.
-
Select ShxPath, and click Change Value.
-
In the Edit Parameter dialog box, click Add New.
-
Enter the folder paths to your custom fonts files, in a semicolon separated list. For example, .\FdFonts;.\DWG_Fonts. Click OK when you are done.
In the absence of custom fonts, default fonts specified by DefaultSHX are used. This parameter is set to simplex.shx, which is delivered to this folder: [installation location]\SmartPlant\Markup\Bin\Igc.Loaders\DWG_Fonts.
-
If you do not want to use simplex.shx, you can force the software to use the TruType font, specified by DefaultTruTypeFont. This is set to Arial by default.
-
Navigate to this folder: [installation location]\SmartPlant\Markup\Bin\Igc.Loaders\DWG_Fonts folder, and rename simplex.shx
-
Rename simplex.shx, forcing the software to use the TruType font.
-
-
Click Done, then Yes to confirm changes.
-
Go to Start > Administrative Tools > Services, and restart these services in the following order:
-
Apache Tomcat
-
Brava! Job Processor
If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the job processor service is called Blazon Job Processor.
-
Blazon Queue Server
-
-
Delete the files in the Brava! Server dlcache folder. This prevents illegible copies cached prior to the changes from being displayed.
You can click Clear Display Cache on the Actions menu of the file or document in the Web Client.
-
Open the file in the Web Client.
-
You can find error messaging in the heartbeat.txt file. For more information, see Detect missing fonts when viewing non-Hexagon PPM CAD files.
-
For more information on using the Loader Configuration Tool, see the Loader Configuration Tool Guide. It is delivered to the following folder on the SmartPlant Markup server: [installation location]\SmartPlant\Markup\Brava! Enterprise\JobProcessor\Igc.Loaders. If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, it is delivered to: [installation location]\SmartPlant\Markup\Blazon\Blazon Enterprise\JobProcessor\Igc.Loaders.