The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.
Problem
Non-Hexagon files do not open using View and Markup with a non-English server installation.
Common Causes
You might encounter this problem if:
-
SmartPlant Markup Plus Server is installed on a VM and DNS resolution fails.
-
The SuppressChildWindows property in the jpconsole.exe.config and/or jpservice.exe.config files is set to False.
-
The NET.TCP Port Sharing Service is not started.
Solutions
Update the queue.server.address.0 property in the job processor configuration file.
-
Log on to the SmartPlant Markup Plus server as an administrator.
-
Open the JobProcessor.config file delivered to the [installation location]\SmartPlant\Markup\Brava! Enterprise\JobProcessor folder.
If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the folder is: [installation location]\SmartPlant\Markup\Blazon\Blazon Enterprise\JobProcessor.
-
Set queue.server.address.0 to the TCP/IP address.
-
Click Start > Administrative Tools > Services.
-
Restart the Brava! Job Processor service.
If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the job processor service is called Blazon Job Processor.
-
Type the following commands at the command prompt:
netsh http add urlacl url= http://*:7070/ user=<[SPMServerMachineName]|[NameofUserRunningBlazonEnterpriseServices]>
netsh http add urlacl url= http://*:80/ user=<[SPMServerMachineName]|[NameofUserRunningBlazonEnterpriseServices]>
netsh http add urlacl url= http://*:8090/ user=<[SPMServerMachineName]|[NameofUserRunningBlazonEnterpriseServices]>
netsh http add urlacl url= http://*:8890/ user=<[SPMServerMachineName]|[NameofUserRunningBlazonEnterpriseServices]>
netsh http add urlacl url= http://*:9900/ user=<[SPMServerMachineName]|[NameofUserRunningBlazonEnterpriseServices]>
Update the SuppressChildWindows property in the configuration files.
-
Log on to the SmartPlant Markup Plus server as an administrator.
-
Open the jpservice.config and jpconsole.exe files delivered to the [installation location]\SmartPlant\Markup\Brava! Enterprise\JobProcessor folder.
If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the folder is: [installation location]\SmartPlant\Markup\Blazon\Blazon Enterprise\JobProcessor.
-
Set SuppressChildWindows to "true".
-
Click Start > Administrative Tools > Services.
-
Restart the Brava! Job Processor service.
If you are using a version prior to SmartPlant Markup Plus 2019 Service Pack 1, the job processor service is called Blazon Job Processor.