The following applies if you are using a version of the software before Update 33 and SmartPlant Markup Plus Server 2019 SP 1 or earlier. For the latest information, see File viewing problems.
Problem
When you click View Files , you see a message like "BravaServer not configured, viewing file natively". The file might then open in another application instead of the browser.
Cause
The file is not available in a WebGL viewer file format, and Web Client is not configured to use Brava! Enterprise Server to display files in the browser.
Solution
Using Server Manager, an administrator sets the BravaServer site property to the location of the Brava! Enterprise Server in the following format: http[s]://[BravaEnterpriseServerName.domain.com]:[PortNumber].
For assistance with using Server Manager, please see Modify properties for a site.
Because you see an error about the BravaServer setting, it is unlikely that WebGL viewer files are meant to be available in your environment. However, an administrator can configure the environment to use WebGL viewer files, if interested. For instructions, please see Configure viewing of Hexagon file formats (retired).