Options Tab (Create Project Dialog Box) - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

Specifies project-level options for changing the model coordinate system, defining which elements are retained, defining default colors, and creating new, smaller .vue files.

Model coordinate system

Transform

Automatically applies any transformation (move, scale and rotation) settings when loading the .vue file the first time after the project database is created. This option is enabled by default.

Large plant monument origin

Uses the large plant monument origin if the project contains a defined large plant monument. In the transform section of a .dri file, values for the old_origin and new_origin are listed. The resulting .vue files created from these .dri files retain the large plant monument origin values.

The transformation section in the delivered spridemo.dri is shown in the following figure:

In the .dri file, if the large plant monument origin is set as (0,0,0), there is no translation and the View > Advanced > Large plant monument command is not active. Smart 3D can create .vue files with large plant monument origin information, and .svf projects can specify large plant monument origin information.

To ignore the large plant monument and keep the coordinate readouts the same as the original coordinate readouts, clear the Large plant monument origin option. For more information, see Large Plant Monument Command.

  • Because of the coordinate differences between the two formats, data such as display sets, comments, and saved views are not guaranteed to be valid if you switch from large plant monument format to regular format.

  • Settings for large plant monument and construction text that exist in the .set file are read in and used in database creation upon initial read-in to Smart Review. These settings include ignore_dri_old_new_origin, ignore_dri_transform, and ignore_construction_text.

  • If you do not have a .set file defining the large plant monument settings or construction text settings, you can define these settings during the initial read-in of the initial database creation by selecting the Options tab on the Create Project dialog box.

Keep DGN File

Construction text

Uses the construction text in the model. For better view manipulation, do not check this option if you have placed construction text at extreme points in the MicroStation model or PDS project.

Lines and line strings

Uses the lines and lines strings in the project. The model display rate is slower when this option is used, depending on the number of lines or line strings in the model.

Named views

Keeps any named views found in the MicroStation design file. MicroStation can save named views to DGN files. If you turn on this option, you can read the named views automatically as Save/Recall views in Smart Review. If there is not an available group, the software creates a new group, Named views, from dgn files in which to save the .dgn file named view. The software saves named views from .dgn files the first time that they are encountered. If the named view exists, it is not overwritten during subsequent sessions. Because of this, any edits that you make in Smart Review to the views are preserved.

Bright default colors

Uses a color table that matches more closely to MicroStation colors. Select the darker colors that Smart Review generates, or use a brighter color table. The brighter color table looks more like the MicroStation colors. Turn this option off to use darker colors.

Resolve PDS duplicate linkages

Creates new, unique linkages for objects contained in PDS .dgn files. When Smart Review creates the new graphics linkages, it also changes the corresponding linkages in the label database (.mdb2). The software replaces the last two values of existing PDS equipment structure linkages with new values based on the orignal values and the current filename.

This option is available in Smart Review and in Smart Interop Publisher for V7 .dgn files or a .dri file containg V7 .dgn files. By default, the option is not active. However, for any PDS-based Smart Models generated by Smart Interop Publisher in which this option was selected, Smart Review honors that setting and the option is automatically selected.

We recommend that you select this option if you are opening files used in a SmartPlant Enterprise environment with SmartPlant Foundation, or if you are having problems viewing object properties and creating display sets based on the graphics.

If you select this option, be aware of the following impacts:

  • Any Intergraph or third-party application usage of the original linkage values from the PDS source data are no longer correct.

  • If you have previously opened the file in a Smart Review project and created any display sets based on linkages, the display sets are no longer valid and must be recreated.

  • You must set Resolve PDS duplicate linkages to the same value (on or off) for .dri, .vue, .svf, or .zvf projects containing the same PDS .dgn source data. This ensures consistent behavior and allows importing and exporting of linkage-based display sets between projects.

Reduce VUE file geometry memory

Creates a potentially smaller .vue file. Smart Review reduces geometry representations as much as possible without losing the rendering compatibility between all Enterprise applications. This means that the display of graphics must be the same whether you are opening the .vue file directly with Smart Review, or adding it as reference 3D data in Smart 3D. This option can cause a longer load time.

After you set the data reduction option, use the Export > Project or Export Main View to VUE commands for Smart Review to reduce the file size.

  • This option applies only for .vue files.

  • When you select this option and then open the .vue file, you cannot re-open the .vue file at a later time and clear this memory reduction option. For example, when a smaller .vue file is created with this option selected, you cannot re-open the .vue file with this option unchecked or cleared, and expect the previous geometry representations to be returned. To open the file without the memory reduction option, delete the .mdb project file, and then open the .vue file in Smart Review. Clear the memory reduction option. Smart Review generates a new project file.