Error Message
The following error message is shown in SPMerror.log:
Specified printer queue name is either invalid or cannot be accessed or No printers are installed.
Possible Causes
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No printer has been installed.
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The printer is incorrectly configured.
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The registry keys are incomplete and cannot be accessed.
Solutions
Install a printer if no printer has been installed:
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Click Start > Control Panel > Hardware > Devices and Printers.
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Click Add a printer.
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Follow the steps to add a printer.
Make sure the Command name and the actual printer address match:
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In the SmartPlant Foundation Desktop Client, click Find > Administration > Printer.
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In the Quick Find box, search using the printer's name, or enter an asterisk (*) to find all defined printers.
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Right-click the printer you are using and click Update.
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To find the printer in the SmartPlant Foundation Desktop Client, the Command name and the actual printer address must match. To confirm the printer address, click Start > Control Panel > Hardware > Devices and Printers. Right-click the printer and click Printer Properties.
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The printer address is displayed on the General tab.
Clean up the system registry entries:
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Log on to Windows as SPFRemoteServices user.
The default password is #1#2#3#4#a#b#c.
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Reboot the computer to make sure the system registry entries are cleaned up.
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For Windows 2008 R2, registry virtualization and UAC features may cause problems. Make sure UAC is turned off.
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SmartPlant Foundation batch printing jobs run as a local user, SPFRemoteServices. Even if you log on as a domain user, the Windows system may return an incorrect registry value. For more information, see Configure PDF generation and batch printing (retired).