Troubleshooting: General Operations - Intergraph Smart Interop Publisher - Installation & Upgrade

Intergraph Smart Interop Publisher Installation and Setup

Language
English (United States)
Product
Intergraph Smart Interop Publisher
Search by Category
Installation & Upgrade
Smart Review Version
2020 (15.0)
Smart Interop Publisher Version
17

Use the information and tips below to help resolve general issues that you might encounter using Smart Interop Publisher.

3D model data does not publish for Smart Documents or Smart Models created with multiple source files.

Deleting the generated .dri file causes Smart Interop Publisher to not publish 3D model data.

  • When publishing updated versions of .pod, .pcf, .igr or .sha 2D drawings with associated 3D model data, copy the updated source files over to the Smart Documents folder containing the original source files. Do not delete the existing .dri file in the folder. This can cause Smart Interop Publisher to not translate and publish the 3D model data. This also applies to updating a Smart Model created by combining multiple .dgn, .dtm, .prp, and .rvm, or .pcf, .idf, and .pod files.

Aspects are not displaying for translated PDMS files.

You must export the data files from your PDMS application for addition and translation in Smart Interop Publisher.

  • To support aspects, you must export the source .rvm file with Representation ON.

Border, Title Block and other elements for a Smart Drawing from P&ID do not display.

When the .pid file is converted to a .vecz file and viewed in the SmartPlant Foundation Web Client, the border and title block information is missing from the vecz file.

  • If you are using .pid files containing links to SmartFrame .igr files in a different file location, you must map the path listed in the .pid source file to the new path location containing the .igr files. This allows Smart Interop Publisher to locate the SmartFrame .igr file during translation to display all objects properly. If you change the path location of the .igr files, you must add or update the version number and new path to the SubstituteDrives.txt delivered in the Smart Interop Publisher install location, and then re-translate.

CADWorx data from the .dwg source file is not displaying in the Smart Model.

  • You must install the CADWorx Plant Object Enabler to view CADWorx Plant components stored in an AutoCAD drawing file (*.dwg). Make sure you have MicroStation V8i SS3 installed. You can install the utility from the PPM Smart Community. Log in to PPM Smart Community and go to Downloads > CADWorx Plant > Freeware Tools and Utilities to get the latest version.

    After you have installed the Object Enabler utility, return to or open Smart Interop Publisher. Select the affected Smart Models in the Smart Models grid in Smart Interop Publisher, and then click Update .

CADWorx: 3DInteropClassID property is missing after translation of .vue files.

  • You must have the exported .drv file in the same folder as the .vue file during translation.

Cannot add or translate IFC files.

  • Smart Interop Publisher supports translating IFC files with a size of less than (<) 2 GB.

Cannot coordinate the color for PDS Legacy source files with Generic mapping.

The Apply Material common translation option does not support PDS Legacy (.dgn + .drv) source files in a Generic mapping workflow.

  • Use default or custom mapping for PDS Legacy source files.

Cannot create a Smart Model.

  • Check if you have the permissions to perform write operations on the Smart Model location folder. Get the required folder permissions or change the location folder to where you have write permissions.

  • Uninstall Smart Interop Publisher and then reinstall.
    Make sure the licensing is installed and licenses are available.
    Retry the translation.
    Contact Hexagon Asset Lifecycle Intelligence support for more information and instructions if the problem persists.

  • Check the version of the source files. You might have to upgrade your third party application to generate supported source files. Also make sure the files are not corrupted. See Supported 3D Model Formats.

  • Check the access permission to the source file and folder.

  • Run Update on Smart Models that have source files that are out of date.

  • Make sure you have loaded the latest Windows updates.

Cannot create a Smart Model. The source file application requires user interaction.

  • Source files from certain authoring applications, such as Navisworks and MicroStation, require the source application to open during the translation. If these applications also require an initial user input, you must enable the desktop interaction option in Intergraph Batch Services. After the application opens for the first time and you enter the required input, you can go back and clear the interaction option for future scheduling.

    1. Open Control Panel > System and Security > Administrative Tools > Services.

    2. Right-click Intergraph Batch Server in the list, and then click Properties.

    3. If not already selected, select Allow service to interact with desktop in the Log On tab, and then click OK.

    4. Re-start the Intergraph Batch Server service.

    5. Verify that the Interactive Services Detection service has been started.

Cannot create a Smart Model or Smart Drawing for a portal target.

  • You cannot have an ellipsis or series of trailing dots (...) in the file name when translating to a portal target application. Rename the file and then re-translate so that folders and files can be created.

Cannot create display sets or use Find Object in Smart Review integrated with the SmartPlant Foundation Desktop Client.

  • This can occur for published Smart Models from third-party application source files. Contact the PPM Smart Community.

Cannot schedule translate or update of CIS/2 source files.

  1. From Windows search, type DCOMCNFG, and then start the executable.

  2. Go to Console Root > Component Services.

  3. Go to Computers > My Computer > DCOM Config.

  4. For CIS/2 files, select the Microsoft Excel Application, and then right-click Properties.

  5. On the Identity tab, select The interactive user, and then click OK.

  6. Return to schedule the source file translation or update.

Cannot schedule, translate, or update Smart Models or source files using the Pipe queue type in Batch Services. This also applies in a Citrix environment.

Set up the interactive user on a system with 64-bit Office:

  1. From Windows search, type DCOMCNFG, and then start the executable.

  2. Go to Console Root > Component Services.

  3. Go to Computers > My Computer > DCOM Config.

  4. Select the Microsoft Excel Application, and then right-click Properties.

  5. On the Identity tab, select The interactive user, and then click OK.

  6. Select the Microsoft Access Application, and then right-click Properties to also select The interactive user.

  7. Return to schedule the source files.

Cannot translate .dtm files.

  • Smart Interop Publisher does not support .dtm files created with Inroads. You must export Inroads .dtm files to a supported format such as .dgn.

Cannot translate MicroStation V7 .dgn source files.

  • Smart Interop Publisher cannot translate converted MicroStation V7 .dgn source files that exceed 32 MB. Clear the Change SmartSolids to Surfaces translation option, and then re-translate the source file.

Cannot translate Navisworks source files.

  • Smart Interop Publisher requires one of the following supported versions of Navisworks to be installed and activated: 2013, 2016, 2017 SP1 and 2018 SP1. Navisworks 2017 and 2018 require the service packs. Load a supported Navisworks version and re-translate.

Cannot translate .rvm files.

  • You must export .rvm files in binary mode only. Smart Interop Publisher does not support .rvm files exported in text mode.

Cannot update a Smart Model.

  • Check if you have the permissions to perform write operations on the Smart Model location folder. Get the required folder permissions or change the location folder to where you have write permissions.

  • Check your source files and make sure they available and not corrupted.

  • Make sure you have loaded the latest Windows updates.

Colon (:) in the custom-mapped property name gets replaced during translation.

  • For MCAD and PDMS source files translations, use a hyphen (-) instead of a colon (:) when you enter any property names that originally have a colon in front of the name. This is because Smart Interop Publisher removes a colon in the front of a property name during translation and replaces it with a hyphen. For example, if you enter :Status, the resulting translation displays -Status.

  • For all other formats, Smart Interop Publisher removes a colon placed inside a property name during translation. For example, if you enter Net:Area in custom mapping the property name, the resulting translation displays NetArea.

Colors are incorrect or are not the colors I need to display for Smart Models from PDMS source files.

  • You can select the Use Custom Colors PDMS options and map a PDMS color index to a specific RGB value.

Complete-with-warnings

  • The software translates the designated drawing files, however, issues were encountered that can affect the Smart Drawing display. Check the generated log file to review the issues.

    One issue applies to fonts. If a font file is not available for portal translation, then Smart Interop Publisher completes the portal translation and lists the missing font names in the generated log file. Install the missing fonts on your system, and then re-translate the drawing file.

  • When translating PDMS source files, Smart Interop Publisher did not find an attribute file for the corresponding .rvm file. The software only reads and processes the graphic data.

    Place the corresponding .att/.datal file(s) in the same folder as the .rvm source file to process the property and graphic data.

Composite document in SmartPlant Foundation containing a Smart Model and 3D Model Data from Smart 3D has incorrect measurements.

  • Use the Advanced option Support SPF Composite model creation with S3D documents in Project Settings option to translate Smart Models used with 3D Model Data in SmartPlant Foundation composite documents. This option allows Smart Interop Publisher to adapt the measurements in the Smart Model to match the measurements in 3D Model Data published from Smart 3D.

    1. Go to the Projects view, and then right-click on the project containing the Smart Models used in the Composite SmartPlant Foundation document.

    2. Select Settings > Project Settings > Advanced.

    3. Click Support SPF Composite model creation with S3D documents, and then click Save.

    4. On the Models view, select the Smart Model in the Smart Model grid, and then click Update .

    5. Select either Default or your custom translation settings, and then click Update.

    6. Select the Smart Model again, and then click Publish .

    7. Check the composite document in SmartPlant Foundation to review the measurements.

Connection problems to an existing site

  • Open SQL Server Management Studio:

    1. Connect to SQL Server instance.

    2. Right-click to detach from the current site: Smart Interop Publisher > Tasks > Detach.

    3. Leave all boxes cleared, and then click OK.

    4. From Smart Interop Publisher, click the IOP Home button , and then click Options > Configure Site Database.

    5. Connect to the site.

      You can also type in the path on the Configure Site Database dialog instead of browsing to it.

Could not be upgraded.

  • There might be an issue with the selected backup folder location. Make sure the user account under which the SQL Server service is running has write permissions to the folder. This can be confirmed by running Services on your system to see which account the service is running under.

Custom classes and properties are not displaying in the target application. The object labels are not available in the selected target application.

  • Check your mapping spreadsheets and make sure the classes and properties have all been mapped correctly. Also, make sure you have set the correct location for your mapping files. You can look in the Smart Models grid at the Mapping File Location column.

  • For data coming from 3D Model Data with custom classes, make sure the Display Name property has been defined.

  • When you save your .xls mapping file, make sure you save the file as an .xls file; do not save it as an .xlsx file. Smart Interop Publisher does not support spreadsheet mapping files with the .xlsx extension.

Custom level mapping using LevelMapping.xls is not honored during scheduled translations.

  • After scheduling a translation, do the following:

    1. Create a 'Desktop' folder in C:\Windows\SysWOW64\config\systemprofile and C:\Windows\System32\config\systemprofile.

    2. Check the folder permissions to make sure access is available.

    3. Update the Smart Model immediately.
      -OR-
      Schedule a translation update.

      See Schedule a Smart Model update job.

    4. For a recurring schedule, go to the Job Manager view and edit the job dates, if required.

DataTools properties from Navisworks source files are missing.

  • To support scheduling and folder monitoring of translating Navisworks files with the Translate DataTools Properties option selected:

    1. Go to the Windows Component Services > Computers > My Computer > DCOM Config folder, and then select Navisworks Document.

    2. Right-click Properties, and then click the Identity tab.

    3. Under Which user account do you want to use to run the application?, select The interactive user.

Document sub type is not valid for the provided document type. Enter a valid document sub type for the drawing file.

You can enter a Document Type and Document Sub Type in the Advanced Tab (Project Settings Dialog) for non-Smart 3D drawings.

  • If the Document Sub Type is not supported in the EFSchema of the registered SmartPlant Foundation server, the publish continues and can succeed, but Smart Interop Publisher displays a warning message indicating an invalid sub type. You can change the sub type and re-publish.

Error Translation Status.

If the software generated a Smart Model but "Error" displays for the Translation Status:

  • If you have any virtual machines (VMs) that are being hosted on VMware ESXi, 6.5.0, you might have to upgrade your VMware toolset to version 11.2.6.x or later.

    -OR-

  • Install the optional VMware, Inc. - Display - 8.17.2.14 Windows Update for your VM. To install the driver on your VM, go to Settings > Update & Security > View Optional Updates > Driver Updates, and then select the driver.

Folder Settings does not show any added or translated source files. It is not working for my remote client systems.

  • Make sure the Intergraph Smart Interop Publisher Folder Monitor service is running. See Start the Folder Monitoring Service

  • Generic mapping not working for PDS Legacy source files.

Graphics are not being translated properly.

  • Smart Interop Publisher does not support non-uniform scaling in source files.

Graphics in portal target applications do not display properly.

If you open a Smart Model that was translated with the Show distant objects common translation setting option in an older version of a web-based application, some or all of the graphics might not display.

  • Turn off the Show distant objects Common options, and then re-translate the file.

Hotspotting does not work for translated Smart Models and Smart Drawings displaying in SmartPlant Markup.

Invalid Action: GetSPFFileTypes

  • Click OK to continue the publish operation. This message displays when you have the Portal and SmartPlant Foundation targets selected while you are publishing to Smart Foundation. To publish when you select both SmartPlant Foundation and Portal targets, Smart Interop Publisher requires a SmartPlant Foundation version that supports portal file types. To get this information, log onto the PPM Smart Community and check Smart Interop Publisher on the Compatibility Matrix.

Inventor file objects only display in grey.

  • Smart Interop Publisher supports graphics color for files created with Inventor version 2012 and later. The graphics color in the translated Smart Model is gray if the source files were created with an earlier version of Inventor.

Licensing issues: Unable to return the license for this session

  • Make sure you have the licensing set up and at least one SIP seat is available on the licensing server. Retry the operation in Smart Interop Publisher. If you are publishing to SmartPlant Foundation, make sure you have an SPF license and an available seat.

  • Check your network connection.

  • Check the translation log file. Smart Interop Publisher creates a [source file name_file type].log file each time you translate source files to Smart Models or Smart Drawings. Smart Interop Publisher places translation information in VUE and ZVF subfolders under the designated Smart Model location.

Lines in the .vue/.zvf/.bin file complex geometry are not displaying.

  • Smart Interop Publisher ignores all lines included in complex geometry when the Reduce geometry size option is enabled during source file translation. You can clear this option and re-translate your source files to see line elements.

Load and consolidate failure after publishing large data sets

  1. In SmartPlant Foundation, increase the timeout values to support large jobs publish. For details, see Configure timeout and other settings for exporting large data sets in the Installation and Setup for SmartPlant Foundation Application Server Help.

  2. Re-publish the large data set with latest version of Smart Interop Publisher and make sure that the publish was successful.

  3. Make sure the Load and Consolidated status is successful and you can do graphic hot-spotting in SPF.

    Some recommended values are listed below:

MicroStation runs out of addressable memory and aborts while translating an AutoCAD file containing proxy objects.

  • Set the MicroStation user configuration variable MS_REALDWG_VERSION to 2012.

Missing geometries in Smart Models translated from CIS/2 or Tekla source files.

  • If the source files contain analytical objects, Smart Interop Publisher only supports physical model objects.

Missing graphical objects and/or Smart Interop Objects in a Smart Model.

  • The default class mapping for source files such as PDMS assigns a generic class for a range of similar objects. This can cause some objects to be missed in the translation. To create a more detailed mapping of objects to specific classes so that the objects visible and distinguishable in a Smart Model, see Use property values for specific class mapping.

Objects from .ifc files saved as Navisworks (.nwd) source files are not grouped together correctly in the translated Smart Model.

  • Use Smart Interop Publisher to directly translate the .ifc file into a Smart Model. Do not perform the interim step of saving the .ifc file into the Navisworks format.

Occlusion not removing expected objects.

  • Occlusion requires a workstation class graphics card in all configurations. The higher-end graphics cards do a better job of removing objects. Lower-end graphics cards remove fewer objects.

Only a few properties and classes are listed when using the GenerateMappingTool.

  • The sheet size for the generic mapping file has exceeded 16384 rows. If you specified multiple .drv files in the GenerateMappingTool:

    1. Group them as smaller sets and then run the GenerateMappingTool utility.

    2. Merge all the generated mapping files into a single mapping file.

Out of Memory error during translation.

  • If you have logging enabled, check the log file size. The log file gets appended during Smart Interop Publisher operations such as translation and can generate large file sizes. Keep the logging option enabled and delete the current log file. Smart Interop Publisher generates a new log file at the next translation.

PDS 3D Smart Model does not publish to SmartPlant Foundation.

  • SmartPlant Foundation requires an .xrg input source file. Make sure the .xrg file is in the same location as the other PDS input source files for the Smart Model. With the Smart Model .zvf selected in the Smart Model grid, click Update and then SmartPlant > Publish .

Problems when trying to split large models into sections. The software created separate objects for the same object contained in multiple Smart Models.

  • By default, Smart Interop Publisher publishes the same object contained in multiple Smart Models as different objects in SmartPlant Foundation. This allows for Smart Interop Publisher to provide Smart Models that can be copied for model data reuse. However, if you have a large model that you have split up into separate Smart Models in which you do not require separate objects to be made in SmartPlant Foundation, follow these steps:

    1. Select the project and then open Project Settings.

    2. Click Advanced, and then select Create a single object for the same object in multiple files.

    3. Save your change and then re-translate and re-publish your Smart Models.

      Because this option changes how objects in the Smart Model are published to SmartPlant Foundation, you must terminate the current Smart Models in SmartPlant Foundation, and then re-translate, and re-publish them in Smart Interop Publisher for the change to take effect.

Publish fails for non-Smart 3D drawings.

  • You can define a custom Document Type and Sub Type for non-Smart 3D drawing source files that are supported in the EFSchema of the registered SmartPlant Foundation server. This helps identify the exact document type for the translated Smart Drawing. The publish fails if the Document Type you enter is not supported by the registered SmartPlant Foundation server.

    1. Select the project containing the drawings to be translated.

    2. In the Project Settings Advanced Tab (Project Settings Dialog), check the specified Document Type and Document Sub Type. Make sure the entered type is defined in the EFSchema file on the registered SmartPlant Foundation server.

    3. Save any edits in the Project Settings Advanced Tab (Project Settings Dialog), and then re-translate.

Publishing problems when SmartPlant Foundation and Portal targets are selected.

  • Smart Interop Publisher requires a SmartPlant Foundation version that supports portal file types. Log onto the PPM Smart Community and check Smart Interop Publisher on the Compatibility Matrix. If you do not have a required version, the publish to SmartPlant Foundation operation continues, but it does not publish the portal files.

Relationships spanning PDMS datasets are lost.

  • If you exported data into separate .rvm/.att dataset files, you can combine them to generate a single Smart Model. This prevents losing any connection relationships at the file split boundaries.

    1. Make sure the .rvm/.att files are in the same folder, and add them to Smart Interop Publisher.

    2. On the Translate Source File Dialog, type a name and location for the Smart Model.

    3. Click Yes to Combine multiple source files into a single Smart Model.

    4. Define any other required translation settings, and then click Translate.

    5. Review the generated Smart Model.

      See Translate PDMS source files.

Scheduling (General Notes)

  • If you change your Windows system password, make sure you update the password in the Intergraph Batch Services server account mapping.

  • Any changes to batch settings or any scheduled jobs related to Smart Interop Publisher using the Intergraph Batch Services program can directly affect job status and Smart Interop Publisher scheduling performance. See Configure batch services account mappings and Set the batch services job run limit.

  • When scheduling jobs to run on a mapped network drive, you must use the Universal Naming Convention (UNC) file path. This applies to all file locations such as the source file, Smart Model, and mapping files locations you must enter in Smart Model translation and project settings.

  • After scheduling a translation of files that lists the status as Complete-No Graphics, or if custom level mapping is not being completed, do the following:

    1. Create a 'Desktop' folder in C:\Windows\SysWOW64\config\systemprofile and C:\Windows\System32\config\systemprofile.

    2. Check the folder permissions to make sure access is available.

    3. Update the Smart Model immediately.
      -OR-
      Schedule a translation update.

      See Schedule a Smart Model update job.

    4. For a recurring schedule, go to the Job Manager View and edit the job dates, if required.

Scheduled translation of .dri files for Smart 3D or SmartPlant Foundation targets does not complete.

  • Enable the desktop interaction option in Intergraph Batch Services:

    1. Open Control Panel > System and Security > Administrative Tools > Services.

    2. Right-click Intergraph Batch Server in the list, and then click Properties.

    3. If not already selected, select Allow service to interact with desktop in the Log On tab, and then click OK.

    4. Re-start the Intergraph Batch Server service.

    5. Verify that the Interactive Services Detection service has been started.

Scheduled translation of MicroStation V8 .dgn files with the Translate each design model separately option does not complete.

  • The Disable Job Inflow... option must be cleared in Batch Services.

    1. From the Start menu, open Intergraph Batch Manager.

    2. Right-click on your queue listed in Batch Servers, and then click Properties.

    3. Clear the Disable Job Inflow while Running Job option in the General tab.

    4. Click OK to save and exit.

    5. Open Smart Interop Publisher and schedule the translation.

Scheduled translation for Navisworks and other source file types does not complete.

  • Source files from certain authoring applications such as Navisworks and MicroStation require the source application to open during the translation. If these applications also require an initial user input, you must enable the desktop interaction option in Intergraph Batch Services. After the application opens for the first time and you enter the required input, you can go back and clear the interaction option for future scheduling. This applies to scheduling selected during the interactive translation workflow and for Folder Settings setup.

    1. Open Control Panel > System and Security > Administrative Tools > Services.

    2. Right-click Intergraph Batch Server in the list, and then click Properties.

    3. If not already selected, select Allow service to interact with desktop in the Log On tab, and then click OK.

    4. Re-start the Intergraph Batch Server service.

    5. Make sure the Interactive Services Detection service has been started.

Scheduled update of some edited Smart Models does not occur.

  • If you make any changes to Smart Model properties, translation settings, export, or project settings in Smart Interop Publisher and do not make any changes to the source files, Smart Interop Publisher does not perform the scheduled update.

    Smart Models get updated only when there are changes to the associated source files. In cases where you edit the Smart Model in Smart Interop Publisher, you must:

    1. Select the Smart Model in the Models view.

    2. Click Update , and then click Update.

Scheduled translate or update operations for folder settings does not occur.

  • If you remove source files from the shared folder that have been scheduled for translation or update, Smart Interop Publisher cannot perform the operation.

    Add the source files back to the shared folder.
    -OR-
    Go to the Job Manager and remove the job associated to the Smart Model created from the removed source files. See Remove a schedule.

  • When scheduling jobs to run on a mapped network drive, you must use the Universal Naming Convention (UNC) file path. This applies to all file locations such as the source file, Smart Model, and mapping files locations you must enter in Smart Model translation and project settings.

Scheduling causes Smart Interop Publisher to become unresponsive when you have a Batch Services run Iimit greater than one, and the Disable Job Inflow while Running Job option is selected.

  • The Disable Job Inflow... option must be cleared in Batch Services.

    1. From the Start menu, open Intergraph Batch Manager.

    2. Right-click your queue listed in Batch Servers, and then click Properties.

    3. Clear the Disable Job Inflow while Running Job check box in the General tab.

    4. Click OK to save and exit.

    5. Open Smart Interop Publisher and schedule the translation.

Smart Interop Publisher does not install or cannot translate certain source files.

When using a display language that contains Unicode formatting (wide characters or multibyte characters) such as Japanese, ensure that the System Locale matches the display language. If you have Unicode formatting characters in the installation folder path, Smart Interop Publisher does not install. In addition, if Unicode formatting characters are in your source file name or folder, or in the shared content folder, Smart Interop Publisher does not translate those source files.

  1. Select Windows Control Panel > Region > Administrative tab, and then click Change system locale.

  2. For Current system locale, select your default language.

  3. Install Smart Interop Publisher or re-translate your source files.

Smart Review displays prompts to upgrade my databases after I updated the .svf project file in Smart Interop Publisher.

  • When you update or schedule an update of the .svf project file, clear the Keep Project Database option.

    1. Select the .svf file selected in the Smart Models grid, and click Update .

    2. On the Update Smart Model dialog, clear Keep Project Database to generate new project and label databases.

    3. Click Update.

Smart Review has stopped working message displays when translating MicroStation V7 .dgn files.

  • Smart Interop Publisher was not able to translate MicroStation V7 .dgn files with occlusion enabled. Turn off occlusion and either re-translate or update the corresponding Smart Model, if one was generated.

    1. Click Close the Program to dismiss the error message and return to Smart Interop Publisher.

    2. Click Projects and select the project containing the V7 .dgn files.

    3. On the Projects view, right-click to select Settings > Translation.
      -OR-
      Click IOP Home > Options > Settings > Translation.

    4. For the Settings Group being used, click Common, and then clear Occlusion.

    5. Click Save, and then click Models.

    6. On the Models view, either select the V7 .dgn source file, and click Translate .
      -OR-
      Select the corresponding Smart Model and click Update .

Smart Review settings and features such as display sets, animations, measurements, and tags are no longer available in my Smart Model after an update.

  • After you have opened a Smart Model in Smart Review and used any features such as display set and animation creation, the settings are stored in the project database (.mdb) file. When you must update the Smart Model, check the Keep Project Database update option so that the Smart Model project database file is not overwritten. In the Smart Model grid, select the Smart Model and click Update . In the Update dialog, make sure the Keep Project Database option is checked.

  • If you created display sets based on DMRS linkages, and then updated Smart Models with the Common translation setting Maintain unique DMRS linkages option selected, you must re-create the display sets with the new linkages. This option causes the software to generate new and unique linkages for each object.

Source files in .dri projects used in automated Folder Settings are not listed in the Source Files grid.

  • For .dri source projects containing other source files, Smart Interop Publisher only shows the .dri files in the Source Files grid.

The .sat files are not being translated. Smart Interop Publisher does not generate a .vue file if translation fails.

  • Smart Interop Publisher does not support binary .sat/.sab files. Export the .sat files from the native software in text mode. Also, the size of the .sat file to be translated cannot exceed 2 GB. If possible, break the file down into smaller files and try again to translate.

The custom classes or properties containing numbers in their labels are not displaying in the target application.

  • Change the cell format of the columns in your mapping file to Text so that numeric values can be translated.

The property class for translated PlantSpace source files shows as Generic.

Unable to create the .vue file.

This error displays when the file size of the translated Smart Model for the Smart Review target application exceeds 4 GB. A generated .vue file has a limit of 4 GB.

  • You can select Smart 3D or SmartPlant Foundation as the target application so that Smart Interop Publisher generates a smaller size .zvf file.

Unable to select and view correlated Smart Drawings or Smart Models in SmartPlant Foundation.

  • To allow the selection of items associated to correlated Smart Drawings and Smart Models, you must publish the Smart Models first and then make sure the publish and load tasks have been completed in SmartPlant Foundation. Then publish and load the related Smart Drawings. This allows you to select items in SmartPlant Foundation, and then use View and Show commands to see the Smart Drawing or Smart Model containing the selected item.

Units of Measure are not correct in the resulting .zvf file when opened in SmartPlant Foundation.

  • You can define a mapping for the Units of Measure (UoM). This involves creating a map unit of measure list definition, and then defining the measurement units to map using the SmartPlant Schema Editor. See the topic Create a Map Unit of Measure List Definition in the SmartPlant Schema Editor Help.