Workflow to Synchronize Catalog Changes between Host and Satellites - Intergraph Smart 3D - Administration

Intergraph Smart 3D Global Workshare (Oracle)

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Administration
Version_S3D
12.x(2018)

The majority of catalog changes are propagated in the Global Workshare Configuration (GWC). However, if new catalog data is bulkloaded at the Host, the workflow depicted in the illustration below must be conducted on the Host server and on all Satellite servers in the GWC. This procedure regenerates the data that is not propagated to the Satellite and returns the workshare to a synchronized state.

Intergraph does not recommend overwriting the Satellite catalog with a copy of the Host catalog and then linking it to the model. Doing so increases the risk of breaking the workshare.

Tasks Performed at the Host Location

  1. Bulkload the required data to the Host catalog.

  2. In the Project Management task, select the Host model in the tree.

  3. Click Tools > Synchronize Model with Catalog.

  4. In the dialog box, ensure Mark out-of-date, Update out-of-date, and Regenerate views are selected, and click OK.

    If the object is owned by the Host, the object is updated. If the object is owned by the Satellite, the object is flagged for update. If a To Do List record is necessary, one is created.

  5. Click Edit > Regenerate Reports Database.

    The software updates the views at the Host only.

    The Reports database is a set of views that point to data in other databases. Although the Reports database does not participate in the workshare, it must be kept up-to-date.

Tasks Performed at the Satellite Location

After the required tasks are completed at the Host location, perform the following tasks at each Satellite location participating in the GWC.

  1. After replication has propagated changes from the Host to the Satellite, run the View Generator against the catalog at the Satellite location. The View Generator executable, ViewGenerator.exe, is delivered in the [Product Folder]\Core\Tools\Administrator\Bin folder. You must select the Catalog as the data database and the Catalog schema as the schema database to run this utility.

  2. In the Project Management task, select the Satellite model in the tree.

  3. Click Tools > Synchronize Model with Catalog.

  4. In the dialog box, ensure that Update out-of-date and Regenerate views are selected, and click OK.

    The software updates the table content and the views on the model. Any objects that are owned by the Satellite are flagged or updated. If a To Do List record is necessary, one is created.

  5. Click Edit > Regenerate Reports Database.

    The software updates the views at the respective Satellite only.

  • Mark out-of-date instructs the software to scan the model database and mark all objects that are out-of-date with the catalog. In Workshare configurations, this option is disabled when the selected model belongs to a Satellite.

  • Update out-of-date instructs the software to update all objects that have been marked as out-of-date in the model database. In Workshare configurations, this option is available for both Host and Satellite locations.