Importing and Deleting Linear Patterns and Styles - Intergraph Smart P&ID - Help - Intergraph

SmartPlant P&ID Options Manager Help

PPMProduct
Intergraph Smart P&ID
PPMCategory_custom
Help
Version_SPPID_custom
7.1 (2014 R1)
Version_SPEM_custom
7.2 (2014 R2)

You can import new linear patterns and styles to use in various ways in symbology and also delete patterns and styles that you do not use.

Linear patterns are imported from symbol files. When you import a pattern, point styles referenced by that file are also imported. In order to assign a newly imported pattern in the Symbology table or heat tracing style in the Tracing table, you must close SmartPlant P&ID Options Manager and reā€‘open it.

You can also delete patterns from the list of available patterns. However, if a style or pattern is in use in SmartPlant P&ID Options Manager, it cannot be deleted.

New linear patterns are created using the Line Style Editor, which is an add-on for Catalog Manager.  Style resource documents can be any .igr document, .spp, or .rsc line style file that contains styles native to that document.  The projectstyles.spp file contains the default symbology.  Using Catalog Manager, you can add projectstyles.spp as a resource.  When you open a new symbol file using the Line Style Editor, all styles are listed.  Styles appearing in bold are currently available to you.  You can modify any symbol file that appears (including styles that do not display in bold) and then you must save the symbol file.  Refer to Catalog Manager Help for details about using the Line Style Editor. 

Using Options Manager, you can import the symbol file.  On the Linear Patterns dialog box, select Import.  Be sure and save to your project style file.  In order to use any imported symbols, you need to update.  You can use the File > Out-of- Date Drawings > Update Drawings command in Drawing Manager or select Tools > Update Symbology in SmartPlant P&ID.  If you use Tools > Update Symbology in SmartPlant P&ID, only the current drawing will update.

  • If you import a new pattern or style that has the same name as a pattern or style that is already listed on the Linear Patterns dialog box, the new information immediately overwrites the older pattern or style.

  • If a linear pattern or style name exists in the projectstyles.spp file with the same name as a filter specified in the Symbology view, then the filter uses that particular linear pattern or style.

  • As soon as you import linear patterns or styles, the new information is immediately written into the project styles file. There is no option to save the changes later.

  • You can also import linear styles, which incorporate linear patterns, for heat tracing symbology.  The words heat trace must appear in the name of the style in order for SmartPlant P&ID Options Manager to import the style.

  • You can chose a different linear pattern and style from the one specified with the filter, by using the Color, Width, and Pattern lists in the Symbology view.