Modify the Offset Distance of Heat Trace Lines - Intergraph Smart P&ID - Help - Intergraph

SmartPlant P&ID Options Manager Help

PPMProduct
Intergraph Smart P&ID
PPMCategory_custom
Help
Version_SPPID_custom
7.1 (2014 R1)
Version_SPEM_custom
7.2 (2014 R2)

The heat trace line offset is modified by setting the offset value in the line style properties for an individual heat trace. The offset value has to be modified for every heat trace line style for which the offset change is required. The workflow is as follows:

  1. Creation of a new symbol in Catalog Manager to be used to edit the line style and import the changes back into the ProjectStyles.spp file.

  2. Referencing the ProjectStyles.spp file.

  3. Importing line styles to be edited from the ProjectStyles.spp file into the symbol file and setting the offset to the desired value using Line Style Editor.

  4. Importing the updated line style from the symbol file back into the ProjectStyles.spp file in Options Manager.

  5. Updating drawings in Drawing Manager.

Symbol Creation and Line Style Definition

As part of the line style definition, you set the value of the offset distance.

  1. Open Catalog Manager and create a new symbol.

  2. Assign a meaningful name to the symbol, for example: HT_offset_modifier.sym.

  3. Display the Line Style Editor.

  4. Reference the ProjectStyles.spp file as follows:

    1. Click Format > Style.

    2. On the Style dialog box, click Resources.

    3. On the Style Resources dialog box, click Add.

    4. In the Add Style Resource window, browse to the active plant’s P&ID Reference Data folder and in the File name field, type ProjectStyles.spp.

    5. Click Open.

    6. On the Style Resources dialog box, click OK.

    7. On the Style dialog box, click Close.

  5. In the Line Style Editor, expand the Linear Styles node.

  6. Right-click on the heat trace line style that you want to modify (for example, Electric Heat Trace) and on the shortcut menu, click Import Style.

    The line style name becomes bold, indicating that it has been imported into the symbol.

  7. Right-click again on the style and on the shortcut menu, click Properties.

  8. On the Linear Style Properties dialog box, in the Offset field, enter the desired offset value.

    The base offset value for heat trace lines is 0.05 in, therefore the actual offset value will be 0.05 in + the value entered in the Offset field.

  9. From the Crossover orientation list, select a value that matches one of the Options Manager Tracing options, such as Top right.

  10. Save the file in Catalog Manager and exit.

Import the Line Style Changes back into the ProjectStyles.spp File Using Options Manager

  1. Open Options Manager and click Tools > Linear Styles.

  2. On the Linear Styles dialog box, click Import.

  3. In the Import Linear Styles From window, browse to and select the symbol with the updated linear styles.

  4. Click Open.

  5. On the Linear Styles dialog box, click Close.

  6. Save the changes and exit Options Manager.

Update Drawings

  1. Open Drawing Manager and select existing drawings that you want to update with the new heat trace style.

  2. Click File > Out-of-Date Drawings > Update.

  • Unlike the default offset distance, a user-defined additional heat trace offset distance will not change dynamically as the zoom level changes in the SmartPlant P&ID drawing view. It is recommended to turn on the Display as printed option (Tools > Options > General) in SmartPlant P&ID to get a consistent look for the offset. This limitation will not affect the print-out results of the drawings.

  • This procedure has no impact on the heat trace line offset in translation output files (.dwg / .dxf / .dgn) created by the SmartPlant P&ID Save As feature.