Setup for Optimal Performance - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
10
Version_SPR
2020 (15.0)

Before you open a model, especially a large model, review the information below on things you can do to improve load and navigation performance. The .vue file size is limited to 4 GB.

Hardware Recommendations

  • Load your data on a solid state hard drive and keep a large amount of free space.

  • Use a high-performance, CAD-oriented graphics card with as much GPU RAM as possible.

  • Keep drivers up to date.

  • Have as much CPU RAM as possible.

  • Have as many CPU cores as possible.

Achieve a Faster Load Time

  • Clear the options listed below in Create Project > Options, especially if you are creating new .vue files to be combined into .svf/.zvf projects.

    • Transform - transforming model data can impact load times.

    • Large plant monument origin - If you do not have large plant monument data, then you do not require this option.

    • Lines and line strings.

    • Resolving PDS duplicate linkages - not required unless you are combining multiple PDS data sources.

  • Select Reduce VUE file geometry memory when creating a new VUE file.

  • For a Smart 3D model in Create Project > Smart 3D:

    1. Clear Maps components to disciplines if you do not have to reorganize the Smart 3D model data into specific disciplines and components.

    2. Clear Remove duplicate geometry if you do not have duplicate geometry issues in an .svf project file containing multiple Smart 3D .vue files.

  • Hide or minimize the Main view during the model load. After the model loads, show or maximize the Main view.

Improve Rendering Performance

  • Remove bad outlier data before creating a new .vue file. Outlier data represents graphics that have been created far away from the main model data or that have extreme ranges.

  • Remove data not required for the review. For example, if you are only reviewing part of the model, do not load the entire model to create the .vue file.

  • Remove duplicate data when creating new .vue file. Avoid repeating the same geometry across multiple .vue files.

Before opening a model, select View > Advanced > Optimize on Model Load for the first-time loading of .vue files or .svf project files. Turn off this option if your model does not require optimization. For example, if your model .vue files were created using ether the Reduce VUE file geometry memory option or the Optimize on Model Load option, then you can clear the optimize option. The option has no impact the second time you open a .vue file or an .svf project file. For more information, see Optimize on Load.

  • When using Smart Review to create a new .vue file, remove transparent graphics or apply non-transparent materials to objects in the model file, level, and color using Tools > Assign Materials and Display Sets > Assign Materials. Select Display Sets > Material Persistence to save material changes for display sets to the new .vue file. For more information, see Assign Materials, Assign Material to Display Sets, and Persist Display Set Material Assignments.

  • Select View > Controls > Performance Control to either the High or Optimal performance setting for faster navigation and motion with some visual quality reduction. For more information, see Set Motion and Display Performance.