Persist Display Set Material Assignments - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

Display Sets > Material Persistence

Toggles on and off the ability to save any material changes made to display sets to another .vue file. When you select this command and use either File > Export > Project or File > Export > Save View to .Vue File, all updated material assignments such as color and textures are saved to the new, generated .vue file. The new assignments become the default material settings for the new .vue file.

When you clear this command, the material assignments are saved only to the project database and are not saved with any new .vue files.

  1. Open a 3D model file and create your display sets. For more information, see Create New Display Set Definitions.

  2. To change the display set appearance, you can:

    • Select View > Controls > Project Manager. Select a display set, and then right-click to select Material.

    • Select a display set in the Main view and then select Display Sets > Assign Materials. For more information, see Assign Material to Display Sets.

  3. Select Display Sets > Material Persistence to turn on the save capability.

  4. Select File > Export > Project to create a new .vue file.
    -OR-
    Select File > Export > Save View to .Vue File to create a new .vue file containing the current contents of the Main view.

    The software saves the new display set material assignments to the new .vue file.