Move, Rotate, and Scale a Model: File Position - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

Edit > File Position

Moves, rotates, and scales plant models used in the current work session. This process is also referred to as Transformation. The File Position command helps in cases when you have two or more plants that are modeled using different source applications. When the plant models are brought into Smart Review, they can be re-sized and re-positioned so that they can be easily viewed and edited. All edits are stored in the project database between sessions.

  • This command is available for multiple .vue files in an .svf project, single .vue files, and streaming .vue files in the .zvf file.

  • The behavior of this command matches the transformation settings and behavior used for Reference 3D modeling in Smart 3D. Results from transformation done in both applications match visually and when measured.

  • The .vue file transformation behavior is compatible with Reference 3D transformation behavior in Smart 3D. Scaling is now done first. Rotation directions are reversed. The display set rotation directions have not changed.

Before you Begin

We recommend that you edit the reference origin point of your display sets to match that of the project file. The graphics contained in the project file are moved or rotated when you transform. However, any display sets you have created can have a different reference origin point than the project file. When you rotate the file, your display sets with different reference origin points do not rotate along with the file. Use the Display Sets > Edit Display Set Position to change the display set reference origin point. For more information, see Change a Display Set Position.  

Move a Model

Follow the steps below to use the File Position command to move a model. For .vue files in an .svf project, you can only move or work with one file at a time. When using a single .vue file or .zvf project, you are working with the entire project model file at one time.

  1. Select Edit > File Position.

  2. From the Information tab in the Edit File Position dialog box, select the file from the File name menu. For an .svf file, select the file to edit.

  3. Click the Move tab. For more information, see Move Tab (Edit File Position Dialog Box).

  4. Type the North, East, and Elevation coordinates for the Reference origin.
    -OR-
    Click Pick Point and click on a location in the Main view.

    The software displays the selected coordinates.

  5. Type or pick the point on the Main view for the North, East, and Elevation coordinates for the Destination. The Absolute, Delta Value, or Delta Direction values define the Destination. Delta defines an offset from the current position, either by a specified amount (value), or by distance and bearing (direction) from the original reference point (Reference origin). Absolute defines the exact destination of the moved display set (not an offset). Click Pick Point to select the 3D point in the model rather than specifying each coordinate individually.

  6. Click the Information tab, and click Transform.

  7. Click Apply to move the model to the specified destination coordinates.
    -or-
    Click OK to move the model to the specified destination coordinates, and close the dialog box.

Rotate a Model

Follow the steps below to use the File Position command to rotate a model. You can only rotate one file at a time.

  1. Select Edit > File Position.

  2. From the Information tab in the Edit File Position dialog box, select the file you want to rotate from the File name menu.

  3. Click the Rotate tab.

    Rotate Tab (Edit File Position Dialog Box)

  4. Type or pick the point for the coordinates for the North, East, and Elevation coordinates for the Reference origin. The Rotate Reference origin is adjusted internally by the move deltas specified on the Move tab before the rotate angles are applied.

  • Click Pick Point to select the 3D point in the model rather than specifying each coordinate individually.

  • Define the reference origin coordinates before you transform the model position.

  1. Specify the Plan, Front, and Side angles.

  2. Click the Information tab again, and check the Transform option.

  3. Click Apply to rotate the model around the specified Reference origin, and then rotate another file.
    -or-
    Click OK to rotate the model around the specified Reference origin, and close the dialog box.

Scale a Model

Follow the steps below to use the File Position command to rotate a model. You can only scale one file at a time.

  1. Select Edit > File Position.

  2. From the Information tab in the Edit File Position dialog box, select the file to resize from the File name menu.

  3. Click the Scale tab.

    Scale Tab (Edit File Position Dialog Box)

  4. Type in the scale factor.

    When using a scale factor, the model is scaled about the specified rotational reference point.

  5. Click the Information tab, and then check the Transform option to scale the model.

  6. Click Apply to scale the model and then size another file.
    -or-
    Click OK to scale the model and close the dialog box.

    The model is always scaled from its origin (0, 0, 0).

See Also

Transformation Settings from Smart Interop Publisher

In the Smart Interop Publisher application, you can set up transformations for files being opened in Smart Review. The transformation settings are placed in a [file name].IOP file, which is automatically read when Smart Review loads a file.

  1. When you open the file for the first time, check the Transform setting in the Options tab of the Create Project dialog box.
    OR
    You can enable the transformation after opening the file from the Edit > File Position dialog box, and selecting the Transform option.

  2. On the Edit File Position dialog box, you can see the transform values in the Move, Rotate, and Scale tabs in the Edit File Position dialog box. You can change the units of measure display using Tools > Format Readouts. You can also change the transformation values in Smart Review, which are written back to SmartPlant Interop Publisher.

    If Smart Review encounters any compatibility issues or problems with the .IOP file, a message displays giving you the option to continue without using the file, or to rename the file. However, renaming the file prevents other Intergraph applications from sharing transformation information. If there is an issue, contact Intergraph Support for assistance.

  3. Define the reference origin coordinates before you transform the model position.