Attach and Review Drawings - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

In Classic mode, you can attach a 2D drawing to a property contained in one or more 3D model objects. Smart Review supports .igr, .sha, .pid, and .spe 2D drawing file types. After you attach the 2D drawing to an object property, you can access the 2D drawing by opening it with an associated external application, or within Smart Review in both Classic and Tablet modes. Follow the steps below to attach the file using the Get External Data command and then display the drawing file.

For .sha and .pid files, you can use the Auto-Attach feature to attach one or more drawing files in a folder to objects in a corresponding 3D model data. For more information, see Auto-Attach Smart 3D Drawings.

Attach with Get External Data

  1. Open your 3D model. As an example to follow for this workflow, you can select the sample MonroviaPlant.vue file delivered in [Install drive]:\ProgramData\Intergraph\SmartPlant\Review\Samples\S3D.

  2. Select a graphic object in the model for the association. As an example, select the Tank equipment object in the Process vessel display set.

    This tank object already has three associated attachments listed in the properties display.

  3. Click Tools > Get External Data > Edit Attachments. See Dialog BoxEdit Attachments Dialog Box

  4. Click Insert on the Edit Attachments dialog box, and then select the property for the attachment. For the example, select Name.

  5. Under Type, click (Default), and then browse to the 2D drawing file to attach. Specify any arguments for the data file in the Arguments box, and then click OK.

    The Edit Attachments dialog box displays the new attachment. As an example, a Distillation Unit A0.sha file has been inserted.

  6. Click OK to close the Edit Attachments dialog box.

    The Tools > Get External Data menu shows the new attachment type:

    All objects that contain the selected property now have the same attached 2D drawing file.

Display the 2D Drawing File in the Document View

  1. Select Window > Document (or CTRL+5) to display the last attached 2D drawing.
    -OR-
    From the Properties dialog box, click the 2D drawing file under Attachments.

    The software tiles the 2D file in the Document view and the 3D model in the Main view. The Document view supports a multi-sheet drawing file. The window is empty until you select a 2D drawing attachment.

  2. You can open a shortcut menu for options such as changing the background color and resetting the view back to its original, Home position.

  3. In Tablet mode, use touch controls or your mouse to move the drawing and selected drawing objects. Use the Search, Home, and Fit commands on the Tablet mode navigation pane with a 2D drawing.

Display the 2D Drawing File in an External Application

To open a 2D drawing file with an external application: you must associate the application to the 2D drawing type:

  1. Select Tools > Get External Data > Edit Types, and then click Insert.

  2. Select an executable from the Select Executable dialog box, and then select a folder from the Default Directory dialog box.

  3. From the Edit Types dialog box, select an existing type or double-click under Type to enter a new one. For example, .sha files can be associated to the SmartSketch application.

    Smart Review calls the external application when you select the 2D drawing file from the Tools > Get External Data menu.

See Also

View Properties and Attachments (Tablet Mode)
Auto-Attach Correlator Utility