Tips on Working with Large Datasets - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
10
Version_SPR
2020 (15.0)

Change Navigation and Display Performance

The Performance Control toolbar provides settings that enable you to move faster through a model or improve the static model display. You can set performance for each model you open in Smart Review. To improve navigation performance, set the Performance Control to Performance. For more information, see Set Motion and Display Performance.

Reduce the .vue File Size

The .vue file size is limited to 4 GB.

Smart Review provides a memory reduction setting to potentially decrease the size of your file so that more graphic objects can be loaded and displayed. The data reduction that can be done, if any, depends on the dataset. The Options tab in the Create Project dialog box provides this setting.

  1. Click File > Open, and browse to the model file to open.

    Smart Review displays the Create Project dialog box if the model is being opened for the first time or if the project and/or label databases have been deleted.

    Use the SmartPlant Review VUE Files as SVF Files filter to display only .vue files that can be added to create an .svf project.

  2. On the Options tab, click Reduce VUE file geometry memory. This option creates a potentially smaller .vue file, however it can cause a longer load time.

  3. Define any other required configuration options, and then click OK. For more information on opening a file and setting configuration options, see Open a Model File.

After you have worked in the .vue file:

  1. Use File > Export > Project or File > Export > Export Main View to Vue File for Smart Review to perform the file size reduction:

    • The Export > Project command saves the entire .vue file as a new .vue file.

    • The Export Main View to Vue File command only exports what is currently in the Main view. For more information, see Export Main View to VUE File.

  2. Close the .vue file, and then exit Smart Review.

  3. Re-open the .vue file.

General Recommendations

The methods listed below can help you manage large datasets to minimize time to load, display, navigate, and find objects. 

  • Use .svf projects to manage loading selected .vue files. The Load Vue Files dialog box allows you to control what is loaded into memory. It is used just like managing what is displayed by turning off and on display sets. Use this feature to keep your memory usage small and manage what you want to see during design reviews. For more information, see Load VUE Files.

  • Use .zvf files, which are generated from Smart Interop Publisher. A .zvf file allows you to access a sub-set of your model data without having to load the entire model. If the entire model data does not fit into memory, portions are still accessible. Only what is in the view is loaded.  The .zvf file approach requires all files to be from the same format such as PDS. For more information, see Open a ZVF File.

  • Use the File > Export > Main View to VUE File command to create new .vue files from existing .vue files. You can export graphics currently shown in the Main view to a new .vue file. Smart Review creates separate .mdb and .mdb2 files for the new .vue file. You can use this feature to create .svf projects by dividing the project into displayable parts that can be loaded or unloaded as required. For more information, see Export Main View to VUE File.  

Adjust Index Allocation

When you work with large datasets, you can improve the performance of your computer by adjusting the Index allocation. Use the following command-line modifiers to adjust the Index allocation:

  • -r specifies that the initial index allocation is in pages of 4096 bytes-per-page.

  • -q specifies that the subsequent index allocation is in pages of 4096 bytes-per-page.

These options affect the r-tree memory allocation parameters of .dri/.dgn files. They have little effect on the total dataset size that can be loaded. The .vue, .svf, and .zvf project files do not use because their r-trees are defined in the project file itself and not allocated as the graphics are loaded.

The software executes the initial -r allocation when the master index is created just before the design data is read in. Any additional allocations use the -q argument for additional indexes to allocate (for example: SPR.exe -r 15000 -q 20). The previous example command sets up 15,000 pages for indexes. Additional indexes are available in 20-page increments.

Recommendations:

  • Estimate 50 pages (r and q units) per MB of Smart Review data.

  • Set the -r allocation much higher than the -q allocation. Use this feature cautiously as you do not want to waste memory.

  • The default values are -r 75, -q 20 if these options are not used on the command line. This size must accommodate smaller models like the example model delivered with Smart Review.