Troubleshooting: General Viewing Issues - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
10
Version_SPR
2020 (15.0)

Problem

Solution(s)

See...

Authorization denied.

From the SPF/SDx server, set the configuration role assignment to the user to ensure proper permissions. Also, make sure you get the data into the desktop client when logged in with the same user ID.

Set the scope value to empty against the oath issuer in the SPF/SDx server web.config file.

Create and manage role assignments and Generating an authorization token using Authorization code with proof key in SPF and SDx Operations Help.

Cannot connect to the server.

Enable Allow Refresh Tokens in your authentication (OAuth 2.0) software application.

Refer to the documentation provided with your authentication software application.

There is a short timespan allowed for signing in. The software might have timed out before credentials were entered.

Enter your credentials within 30-40 seconds of the sign-in prompt.

Cannot copy 2D drawing documents when connected to an SPF Foundation, SPF Web Client, or SDx server. The Cannot get data from the server error message displays.

Disable the Do not save encrypted pages to disk option in Internet Explorer advanced Internet Options to continue.

MS Windows O/S Help on security and internet options.

Cannot get data from the server.
-or-
User cannot be found.

To connect to the SPF or SDx Operations server, your user name and permissions must also exist on the SPF or SDx Operations server. Check the name and permissions you are using to log into your authentication software and into your SPF or SDx Operations server.

Export and Connect to SPF/SDx Operations

Create and manage role assignments

Cannot open a .vue file.

The .vue file size is limited to 4 GB. You can break up the model into separate .vue files and create an .svf project file.

Tips on Working with Large Datasets

Create an SVF Project

Cannot open an existing .vue file.

Generate a new Smart Review VUE file from the original model data set. SmartPlant Review supports reading any VUE file produced by SmartPlant Review 05.01.00.02 or later. However, the VUE files produced by SmartPlant Review 06.02.00.17 or later cannot be read by earlier, released versions.

Open a Model File

Export > Project

Changes do not appear in the view.

Refresh the view or refresh the data.

Refresh Command

Refresh Data Command

Client application is not known or is not authorized.

A Smart Review client has not been created on the SPF/SDx server.

Refer to Register applications in the SPF/SDx Help.

Generated Collision Detection report (.htm) file entries do not display correctly for non-English characters.

The HTML file created from the Detect Collision dialog box reporting uses an embedded unicode header (UTF-8).

This universal header tag allows you to select the locale/encoding in your selected internet browser for the region in which you live. This character encoding browser setting displays the correct language character set for your selected region.

For example, in Internet Explorer 9, click View > Encoding > More > [language], and select the required language. This allows you to see the correct character set for the generated collision detection .htm file.

See the documentation provided by your web browser software for more information on encoding and language settings.

Invalid scope

The resource scope has not been added for the Smart Review client on the server.

Refer to Register applications in the SPF/SDx Help.

Jagged edges on objects

Turn on hardware anti-aliasing if your video card supports it. Select your system control panel display settings to access your video card settings. Download the current display driver from your video card manufacturer rather than using the generic display driver delivered with your operating system.

See the documentation provided by your video card manufacturer for more information about turning on hardware anti- aliasing.

Lost in the view.

Click View > Fit > View to Model. The current active view is updated.

Working with Views

Fit View to Model

Main view is blank but Plan and Elevation views display the model.

Move the eye point and adjust the view cone.

Set Eye Point

Set Clipping Planes

Fit View to Model

Missing properties from PDS source files or incorrect display set resolution.

Model graphics linkages might not be synchronized correctly with the label database (.mdb2) linkages.Recreate either the model files (.vue/zvf) or the label database (.mdb2) linkages with the Resolve duplicate PDS linkages Create Project option on or off. If the model was translated using Smart Interop Publisher, you can re-translate the file with that option on or off, and then open the resulting Smart Model in Smart Review with the option selected.

Options Tab (Create Project Dialog Box)

Not enough licenses are available.

Before Smart Review can run, you must free enough currently in-use licenses to cover the modules to run, or you must use the Select Modules utility to unselect the modules for which you cannot currently obtain a license.

Select Licenses for Modules

Objects in my new display set do not appear.

Possible overlapping display sets. The last action performed on the object by corresponding display set manipulations wins.

Working with Display Sets

Part of the model appears cut off.

Adjust the front and back clipping planes.

Set Clipping Planes

Provided redirect URI is not registered for the client.

Add the redirect URI http://127.0.0.1/ for the Smart Review client in your authorization server.

Connect to a Smart 3D Server

Saved image contains overlapping image that you do not want.

Make sure windows, dialog boxes, toolbars, and so forth are not overlapping the view, then refresh all views.

Refresh All Views

Stereo viewing depth perceptions appear mostly flat or turning the glasses upside down corrects the view.

Change the stereo polarity by clicking View > Advanced > Stereo, and then selecting either polarity direction. Right is the normal and default polarity direction setting. However, left may be necessary on some setups, particularly projection system.

View in Stereo

Views are blank or objects seem to be missing or hidden.

Check the view settings (increase tolerance).

Make sure that the eye point and the center point are not set to the same, or nearly the same, values.

Check the settings for levels and display sets.

View Settings Dialog Box

Level Settings Dialog Box

Working with Display Sets

Set Eye Point

Set Center Point