View Object Properties - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
10
Version_SPR
2020 (15.0)

View > Controls > Properties

Displays object properties in Classic mode 3D and 2D views. The information in the dialog box is read-only. Data displayed in the Properties tree view is taken from the current project label database (.mdb2) file. The contents and the hierarchical display of the object data depend on the source application used to create the model (such as PDS, Smart 3D, or SmartPlant Foundation).

Text Window vs. Properties Dialog Box

The Text view (Window > Text) lists the object data hierarchy (if any) from the bottom-up while the Properties dialog box switches to a top-down presentation after the base data is listed. Hyperlinks in the label description or for attachments can be accessed from both windows.

View Properties

By default, the properties specific to the selected object display at the top. Follow the steps below to open the Properties dialog box.

  1. Select an object in the model.

  2. Click View > Controls > Properties.
    -OR-
    Right-click to open a context menu and select Properties.

    • You can also use the key combination ALT+7, or click Properties in the common toolbar.

    • Move or dock the Properties dialog box to other controls such as the Project Manager or onto the Main view.

      Properties Dialog Box

  3. Select another object in the Main view and the property display changes to show the selected object properties.

    You can change the tooltip content by selecting a specific label or relational data row property in the Properties dialog box. The tooltip label for the next selected object shows the specified property value. The software uses the value of the last occurrence of that label name. Select a different, non-label name to return to the default behavior.

    The example below shows the Date created property selected and the value displays in the tooltip.This allows you to quickly see a specific property value for each object you select in the Main view.

  4. You can search for specific graphic, label or system data from Properties. Select the name and then right-click to select Search. For example, select an item such as Component under Label Data, and then type the search criteria.

    Search displays all component information, lists the number of items that meet the criteria, and displays the corresponding objects in the Main view.

  5. You can open any files listed under Attachments. For 2D drawings associated to an object:

    1. The 2D drawing displays in the Document view and Smart Review automatically resizes the Main view. Adjust the views as required to see both the 3D model and the 2D drawing.

    2. To see multiple sheets within a drawing file, tab through each sheet listed in the Document view.

    3. When you select a Smart 3D graphical object in the Main view, Smart Review automatically selects that graphical object if it is in the displayed 2D drawing in the Document view, and vice versa.

See Also

Show or Hide All Properties
Sort Properties
Attaching External Data
Compare Object Properties