Export Main View to VUE File - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

File > Export > Main View to VUE File

To use this functionality, you must install the Application Programming Interface (API) module. Also, this command is not available for .svf projects.

Exports all the graphics currently shown in the Main view to a new .vue file. Smart Review creates separate .mdb and .mdb2 files for the generated .vue file. These databases contain only the information about the graphics present in the exported .vue file. This enables you to quickly create a .vue file of a model showing specific graphics. This command is not active if you have a .zvf or .svf project file open. For more information about exporting, see Tips for Data Reduction During an Export.

This command exports visible data where visibility is defined by:

  • The display set show and hide states for the graphics in the model.

  • The level show and hide states for the graphics in the model.

  • Graphic ranges that overlap the Main view and/or clipping volume (if active).

  • Graphic ranges larger than any current Main view range rejection screen pixel size setting.

Follow the steps below.

  1. In Smart Review, open the model containing the graphics to export.

  2. (Optional) On the Options tab of the Create Project dialog box, click Reduce VUE file geometry memory. This option creates a potentially smaller .vue file. Smart Review reduces geometry representations as much as possible without losing the rendering compatibility between all SmartPlant Enterprise applications. This option can, however, cause a longer load time.

  3. Click View > Controls > Project Manager. Alternatively, press ALT + 0.

  4. Navigate within the Main view to where you can see just the remaining objects to export.

  5. To hide any display sets of graphics, select the display set, right-click to open a shortcut menu, and clear Show. Otherwise, a checkmark displaying beside the Show toggle command means that the selected display set is shown in the Main view and can be exported.

  6. To hide any file levels of graphics not required for the export, select each file under Project files and for the Main view, click All Off.

  7. Click View > Advanced > Range Rejection > Main and adjust the Main view range rejection settings to hide any objects for the export. For more information, see Applying Range Rejection.

  8. Activate and adjust a clipping volume to further clip out unnecessary objects. For more information on clipping volumes, see Working with Clipping Volumes.

  9. (Optional) Select Display Sets > Material Persistence to save any material changes you have made to display sets in the new .vue file. For more information, see Persist Display Set Material Assignments.

  10. Click File > Export > Main View To Vue File when you have finished setting up the display sets in your Main view.

  11. Select the destination folder for the new .vue file and type in the file name.

  12. Click Save.

  • When creating display sets, the Picked Objects search criteria should be used only in the current data set. The portion of display sets created using the Picked Object search criteria can be lost when the definition is edited in a subsequent or exported Smart Review session. The picked objects can also be lost if the display set definition is loaded using the Load Display Set form, or if the files containing these elements are modified.

  • In the resulting .vue file, you may see objects that were not in the Main view. This is because the export process does not separate or break apart graphic objects and linked objects. Graphic objects, which are linked by their common primary linkage, are never exported separately. If any graphic object in the list of linked objects is exported, then all other graphic objects in the list are also exported.

  • Current graphic material transparency does not determine if a graphic object is exported. That is, even if the object is too transparent to be seen in the Main view, it is still exported (glass-type material, for example).

  • Objects not visible in the Main view may still be exported if their ranges overlap the main view and/or clipping volume (if active). If this is an issue, hide these objects using display sets or level settings.

  • This command does not export graphic objects that are hidden by active near clipping, far clipping, clipping volume, range rejection settings, level settings, or display set settings.

  • If you edited your mapping text file to change the file and level organization for the model, the new organization is saved in the new .vue file.

  • Smart Review does not export the active ground plane or imported 3D objects.