Export Main View to FBX - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

File > Export > Main View to FBX

To use this functionality, you must install the Photo-Realism module.

Exports all the objects visible in the Main view to either a binary or ASCII .fbx (ver. 7.5.0) file format. This allows you to open the exported file in a variety of third-party FBX file viewers. While binary is the standard format for .fbx files, the ASCII text format gives you a text version so that you can search the .fbx file for information retrieval. This command applies to .vue, .svf, and .zvf project files.

When you first open a file containing the model data to export, select the Reduce VUE file geometry memory option on the Create Project > Options tab. Smart Review reduces geometry representations as much as possible without losing the rendering compatibility between all Smart Enterprise applications.

The Export > Main View to FBX command exports visible data where visibility is defined by:

  • The display set show and hide states for the graphics in the model.

  • The level show and hide states for the graphics in the model.

  • Graphic ranges that overlap the Main view and/or clipping volume (if active).

  • Graphic ranges larger than any current Main view range rejection screen pixel size setting.

Export

When you export to an FBX file, Smart Review exports the objects and their corresponding properties.

  1. In Smart Review, open the model containing the graphics to export.

  2. Navigate within the Main view to where you can see just the objects to export. There are several ways you can use Smart Review display commands to control the objects contained in the Main view for the export. For more information, see Techniques for a concise export.

  3. When you finish setting up your Main view content, click File > Export > Main View FBX .

  4. Select the destination folder for the new file and use the default name or type in the file name.

  5. For Save as Type, select either FBX binary or FBX ascii for the format content, and then click Save.

    Smart Review performs the export, and then places the .fbx file in the designated folder. Use your own third-party FBX viewer to open the exported file.