Add and Edit Attachments - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

Tools > Get External Data > Edit Attachments

Displays the Edit Attachments dialog box, which allows you to add, edit, or remove files associated with the selected object in the open project. Changes made using this command also alter the entries on the Get External Data menu. The file associations are saved to the Microsoft Access Get External Data database file for the project.

You can attach virtually any file type to an object in the project, such as Microsoft Word, Excel, and PowerPoint files; ASCII text files from Notepad or from the Smart Review Text window; MicroStation files, sound, animation, and Video Engine files. Executable files and their associated files must exist before you attach them.

You can also correlate and attach one or more Smart 3D drawing (.pid or .sha) files to 3D objects in the model with Auto-Attach. For more information, see Auto-Attach Smart 3D Drawings.

Attach External Data to a Project

  1. Select a graphic object in the model.

  2. Click Tools > Get External Data > Edit Attachments. If you select an object in the project that contains no property data and no attached data, the Edit Attachments button is not active.

    Edit Attachments Dialog Box

  3. Click Insert on the Edit Attachments dialog box, and then select the label data property for the attachment. To create a unique mapping between an object and document attachments, select Linkages. Otherwise, you can have the same document attachments associated to multiple objects. For example, if you select the object Name for the attachment, then all objects with the same value for Name also have the attachment.

  4. Click the added row containing the selected property to display the Edit Filename / Argument dialog box. Browse to the data file to attach, specify any Arguments for the data file, and then click OK.

  5. Click OK to close the Edit Attachments dialog box.

    The Tools > Get External Data menu lists attached documents.

  • Attaching a file to a property value of one element automatically attaches the file to every element with the same attribute value.

  • To remove an attachment, select the attachment in the list, and then click Delete on the Edit Attachments dialog box. This removes the attachment from the display in Smart Review, but does not delete the actual file.

See Also

Attaching External Data
View Object Properties
Text Command