View the Assembly Breakdown Structure - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
10
Version_SPR
2020 (15.0)

View > Controls > Assembly Breakdown Structure

Provides a hierarchy that lists objects that have assembly relationships. The assembly hierarchy can be generated from Hexagon PPM (.vue, .zvf, .svf) files or from non-native files translated using Smart Interop publisher.

When you load, unload, add, and remove .vue files from an .svf project, the software refreshes the hierarchy contents and collapses the tree view display. If you select the Single label database option when creating an .svf project, the system hierarchy always loads all the label data contained in the .svf project.

On the Assembly Breakdown Structure window, you can access shortcut menus to:

  • Temporarily show and hide selected single objects or objects within a selected area or unit.

  • Create a display set from selected single objects or objects within a selected area or unit. The software uses the selected node name as the default name for the newly-created display set.

  • Isolate selected single objects or objects within a selected area or unit.

  • View properties.

  • Expand or collapse all nodes.

  • Dock the window anywhere on the Main view.

  • Search for specific objects in the selected node.

Hierarchy icons specific to the Assembly Breakdown Structure include:

Icon

Description

Block - a high-level assembly that is a spatial definition of a section of the model structure. Blocks are created by splitting a volume. Blocks contain assemblies, parts, and/or child blocks.

Assembly block - A collection of blocks, assemblies, structural parts, equipment, outfitting parts, and outfitting assemblies (such as pipe spools). An assembly block can be a child of the top-level block or another assembly block.

Assemblies - A collection of assemblies, structural parts, equipment, outfitting parts, and outfitting assemblies (such as pipe spools). An assembly can be a child of a block, assembly block, or another assembly.

Smart Review displays the Isolate Objects, New Display Set, and Show commands only when the selected node or sub node has at least one corresponding graphic in the Main view. Hidden notes are italicized.

Assembly Breakdown Structure General Workflow

  1. Select View > Controls > Assembly Breakdown Structure.
    -OR-
    ALT + Y.

    Smart Review reads the database (.mdb2) file to create the hierarchy for display.

  2. As the software loads the hierarchy, open the Text view (Window > Text) to see the load progress. If the software cannot create a structure hierarchy from the associated label database file, the No Structure icon displays in the window.

    Any errors the software encounters when creating and loading the hierarchy display in the Text view. For more information on resolving structure display, see Troubleshooting: Loading the System or Assembly Breakdown Structure Hierarchy.

  3. Expand the top model node to load the hierarchy. You can move the Assembly Breakdown Structure window or dock it onto the Main view.

  4. Select a node. Use standard SHIFT+ and CTRL+ keys to select multiple nodes.

    The software automatically selects all sub nodes and the corresponding graphics highlight in the Main view. You might have to select Fit to locate the objects.

    By default, you can select graphic objects in the Main view, and the software automatically selects the corresponding nodes in the hierarchy. To turn off this behavior so that the Assembly Breakdown Structure display and the Main view selection are independent of each other, clear Edit > Select Filter > Sync in SBS/ABS. For more information, see Sync in SBS/ABS.

  5. You can select objects and perform operations such as clipping, commenting, and using saved views to further refine and manipulate your model view.

Using the Assembly Breakdown Structure

  1. Select a single object in the hierarchy tree view, or select a node.

  2. Click Fit to zoom in closer to the selected graphics objects. The following example shows the selected node and associated graphic objects in a sample model.

  3. Right-click to open the shortcut menu, and then clear Show.

    The software hides the selected objects from the Main view. The label for the currently-hidden objects display in italics. Objects are hidden only in the current work session.

  4. To show the objects again, right-click on the italicized node label, and then click Show.

    The software does not save Show and Hide settings between work sessions.