Define Settings and Server Connections - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

Tablet Mode > Expand > Settings
-OR-
File > Settings

Provides two types of options. The Sources options allow you to connected to a remote server and manage your server connections. The Visuals options allow you to change the Main view display in Tablet mode.

Sources

For server connection functionality, you must install the Application Programming Interface (API) module.

Manages the connection to remote servers. Smart Review allows you to create server connections through a third-party token service application to access data; the data you can access depends on the server type as described below. Smart Review supports connection to one server at a time.

Server Connections

Use Sources to:

  • Connect to a Smart 3D server to see live 2D drawings that are correlated to the open 3D model. You can then copy the 2D drawings locally and attach them in Smart Review. For more information, see Access 2D Drawings.

  • Re-connect to a previously connected SmartPlant Foundation or SDx Operations server to see both 2D drawings and property data. When you open Smart Review from within a SmartPlant Foundation or SDx Operations session, you can use Export > Project to save the model .zvf file to a different folder location (local or remote). Smart Review stores the connection information in the project database .mdb file. When you open the saved model, Smart Review automatically attempts to connect to the server. For more information, see Export and Connect to SPF/SDx Operations and Access 2D Drawings.

Connect to a Server

The steps below provide a general workflow for obtaining a server connection. For more information on software requirements, see Requirements for Server Connection.

  1. Open the model, and then select File > Settings.
    -OR-
    From Tablet Mode, tap Expand and then tap Settings.

  2. Select Sources > Edit and then enter the web URL address of the server for data retrieval.

  3. From Sources, enter the Web URL address of the Smart 3D server for data retrieval. If you already have a previous connection, click More and then select Edit to enter the Smart 3D server web URL.

  4. Tap Save.

  5. Tap More , and then select Connect.

  6. Sign in with any required credentials you or your system administrator set up for the server.

    Connection example:

    Smart Review maintains the connection until you disconnect or open another model.

    Smart Review automatically saves the connection information to your project database .mdb file. When you share the project database, the connection information is automatically shared.

  7. Close Settings.

Visuals (Tablet Mode)

Provides option to quickly change the 3D model display. For a faster display and navigation performance, the following settings are turned off by default:

  • Source lights

  • Background images

  • DTM file graphics

  • The Visuals tab is only available in Tablet mode and only enabled if Smart Review is using graphics card acceleration.

  • Anti-aliasing uses your system’s display adapter to smooth surfaces in the model. You can use Anti-alias in the Main view by itself or in combination with Shadows and Outline settings in which the outline width is set to 2 or 3.

  • Ambient Occlusion is not supported for snapshots.

Outline

Turns on and off the outlining of 3D objects. For more information on how to configure outline options such as the line width and color, see Outline Tab (View Settings Dialog Box).

Ambient Occlusion

Turns on and off a more realistic object lighting. Ambient Occlusion accentuates small surface details and adds soft shadows.

Shadows

Turns on and off the casting of shadows in the view. For more information on editing shadow effects, see Lighting Tab (View Settings Dialog Box).

Reflections

Turns on Reflective Phong Shading mode for the highest quality rendering of 3D objects using smoother (pixel level) shading. This setting also provides environmental reflections that are based on the object’s material properties. Rendering performance can be impacted more than the Phong Shading mode. The higher the material’s Reflectivity setting, the more pronounced the effect. The material’s Pattern Weight controls blending this effect with the material’s texture (if any). For more information on Reflectivity, Pattern Weight, and other material options, see Edit Materials Dialog Box.

Environment

Turns on and off the current environment settings which can include a gradient background and a ground plane. For more information on how to configure environment settings, see Create a Gradient Background, and Create a Ground Plane.

See Also

Configure View Settings
Working in an Integrated Environment