Open a Model File - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2019 (10.0)
Version_SPR
2020 (15.0)

File > Open

Opens a file that can be read by Smart Review. Supported files include:

  • .vue

  • .zvf

  • .svf

  • .dri

  • MicroStation .dgn/.prp/.dtm

You can only have one file open at a time. If there is already an open model, Smart Review closes that model and then opens the new one. To view models from third-party authoring tools such as PDMS, AutoCAD or ACIS, you must first translate the model using Smart Interop Publisher. You can then open the resulting .vue, .svf, or .zvf file in Smart Review.

  1. Before you open the file, review some tips and options you can set to improve your file load and rendering performance. For more information, see Setup for Optimal Performance.

  2. Select File > Open. If you are opening a model with existing project databases created by a previous version of Smart Review, the software upgrades these databases to the currently supported version. You can also open a .vue file from a command line prompt or by dragging and dropping it into the Smart Review window.

    Smart Review checks that the project file name is the one specified in the project database.

    If the opened project file name does not match the project database file name, Smart Review functionality does not work correctly. Smart Review displays a message for you to click one of the following options:

    • Yes - Converts to the new project file name. The conversion allows you to create new data using the new project filename specifications. Before you select this option, we recommend that you make a backup copy of the project and label databases.

      The conversion does not update existing data such as display sets, assigned materials, and level settings that keyed off the previous project file name. You can delete and recreate or edit the existing data as required.

      No - Leaves the file unopened. You can rename either the project file or the database files, and place them in different folders. You can then create new project and label databases with matching file names.

  3. In the Open dialog box, select the file type extension, and then browse to the file to open. To list only .vue files that can be added to create an .svf project, select SmartPlant Review VUE Files as SVF Files.

    The Create Project dialog box displays if the project (.mdb) file is not available or cannot be located.

    The Create Project settings allow you to create both the project (.mdb) and label (.mdb2) database files. However, if you delete the .mdb2 file that corresponds to a project file generated from Smart Interop Publisher, you cannot use Smart Review to recreate it. You must go back to Smart Interop Publisher and update the model to get the required database files. For more information, see the Update Smart Models topic in the Smart Interop Publisher User's Guide.

  4. On the Database tab of the Create Project dialog box, browse to or type a location for the Project Schema and Label Schema files.

    Database Tab (Create Project Dialog Box)

  5. Type a name and ID in the Site Name and Site ID boxes. The site name and site ID provide identification information for the project. This information is stored in the project database. Defining specific site names and IDs can help your administrator identify where the data in the project database comes from.

  6. Select or clear the Single label database option. By default, this option is off and Smart Review reads in the data from the .mdb2 file for each .vue file contained in the .svf project. For more efficiency and faster subsequent load times, select the option to create a single database for an .svf project. For information on additional file options, see Options Tab (Create Project Dialog Box)

  7. If you are opening a Smart 3D (.vue) file or a local Smart 3D (.svf) project, specify the paths to the files requested on the SmartPlant 3D tab.

    Smart 3D Tab (Create Project Dialog Box)

  8. Click OK to save the project settings.

    Smart Review opens the file.

When a .vue file is opened, Smart Review displays a coordinate axis in the lower left corner of the view.

The view axis shows the direction is E (x axis), N (y axis), and El (z axis):

  • The N arrow always points in the direction of plant North in the model relative to the current view.

  • The E arrow always points in the direction of the plant East in the model relative to the current view.

  • The El arrow always points to the Elevation of the plant in the model relative to the current view.

  • You can change the path (folder location) to the project databases, but you cannot change the names of the databases. The names are based on the name of the model document.

  • If Smart Review encounters a bad element, a message appears in the Text window indicating that the software found an element of a particular geometric type. The message also gives the block and byte location of the element in the .dgn file. You can use a tool such as MicroStation EDG to repair many bad elements.

  • If you do not have a .set file defining the large plant monument settings or construction text settings, you can define it during the initial read-in of the initial database creation by selecting the Options tab on the Create Project dialog box.

  • Smart Review does extensive range validation on geometric elements. Elements that are off the design plane are considered bad elements. To accommodate large plant monument data, the current validation range is the large plant monument point, if one exists, plus or minus 4294967294 units of resolution (UOR). Smart Review alerts you to the problem element with a message in the Text window. You can log Text window messages to a text file for later review.

  • Settings for large plant monument and construction text that exist in the .set file are read in and used in database creation upon initial read-in to Smart Review. These settings include ignore_dri_old_new_origin, ignore_dri_transform, and ignore_construction_text.

  • In the standard Smart Review product, there is no longer a limit on the large plant monument range. However, if you use the API to recall saved views, the maximum new origin is the range -2147483647 to +2147483648. You can bypass this limitation with the API by getting the eye and center point information directly from the database after you save any changes to views in the current session.

  • The only way to set these options again is to delete the project database files (.mdb and .mdb2) and then re-open the model file to create a new project database file. You also can change the name of the model file to start over with a new name.

  • Because of the coordinate differences between the two formats, data such as display sets, comments, and saved views are not guaranteed to be valid if you switch from large plant monument format to regular format.