Custom Commands - Intergraph Smart 3D - Help

Intergraph Smart 3D Reports

PPMProduct
Intergraph Smart 3D
PPMCategory_custom
Help
SPFVersion_custom
7.1 (2018 R1)
Version_SThreeD_Custom
11 (2016)

Provides you with application programming capability for the 3D software. Using Microsoft® Visual Basic, you can create a custom command that groups a series of commands and instructions into a single command that runs as an operation in the 3D software. As a result, you can access the customized commands that directly relate to the work routine in your operation.

In Visual Basic, the Command Wizard helps you to build a custom command. For example, the first Command Wizard step prompts you to identify general information, including command name, project name, author, and company. You can start the wizard in Visual Basic by clicking Command Wizard on the Add-Ins menu. For more information about installing the Command Wizard and other programming resources, see the Intergraph Smart 3D Installation Guide available by clicking Help > Printable Guides in the software.

After adding a custom command in the 3D software, you can edit it. The Edit Custom Command dialog box requires you to specify the program identifier (prog_id), command name and description, command priority, and a command line of arguments in a string.

Delivered Custom Commands

The following list provides descriptions and ProgIDs for the delivered custom commands:

Custom Command

ProgID

Description

Check Database Integrity

SP3DCheckDatabaseIntegrity.
CCheckObj

Creates records for the objects that need to be cleaned. You run this custom command directly on a database (Site, Catalog, or Model). After you run this command, you can generate a report to review the errors that the Check Database Integrity command generated. For more information on the Check Database Integrity command, see the Database Integrity Guide available from Help > Printable Guides.

Clean Database

SP3DCleanDatabaseCmd.
CCheckObj

Deletes or cleans an object. This command is used when an action on the Check Database Integrity report is To Be Removed or To Be Repaired. For more information on deleting and cleaning objects in the database, see the Database Integrity Guide available from Help > Printable Guides.

Create Drawing View

MenuDrawView.
CMenuDrawView

Saves and converts the contents of a three-dimensional graphic view window into a snapshot view. The command creates a rectangular object associated to a clipping volume or volumes in the three-dimensional model.

Before you create a snapshot view using this command, you must have added at least one composed drawing type to the Management Console in the Drawings and Reports task.

You can save additional views by updating the view contents and then saving the new design. If you used the Tools > Hide command to avoid displaying certain objects, those objects are included in a composed drawing you create.

You must have appropriate permissions to access composed drawing types, or you cannot use the Tools > Snapshot View command. If you have only read permission, you receive a message that alerts you to this condition.

After you create the snapshot views, you can add them to composed drawings when you use the Tools > Drawings Console command.

Drawings Check and Repair Utility

DwgCheckUtility,Ingr.SP3D.
Drawings.Client.Commands.DwgCheckUtility.
RunChecksCmd

Checks drawing items for problems, such as mismatches between views, smartframes, and OIDs; duplications of views, smartframes, and OIDs; and invalid dimensions with missing smartframe attributes. After problems are found, you can run repairs.

This command is intended for use by your administrator.

Find Object by OID

SP3DFindObjectByReport.
FindObjects

Finds objects with integrity problems in a graphic view. Before running this command, you must define your workspace to include these objects. Run a database integrity report, and use the reported OIDs of the objects in the workspace definition. For more information on the Find Objects by OID custom command, see the Database Integrity Guide available from Help > Printable Guides.

Fix Project Root

SP3DPRJMGTRepairCmd.
FixCnfgProjectRoot

Synchronizes the model name in the Model database and the Site database. The name in the Site database prevails.

You must run this command from a task in the model, not from Project Management.

Fix Sector Size of Documents

DwgBinaryEditorCmd.
FixSectorSize

Adjusts the sector size from small to large. Documents that have many sheets and a small sector size can cause the software to run out of memory.

Reset Design Basis Time

IMSEngFrameworkCmd.
EngFrameworkCmd
Argument = ResetDesignBasisTime

Modifies the Design Basis timestamp. With this command, you can set the time and date back to a point in the past. This command is useful if, for any reason, there are delete instructions that could not be processed.

Synchronize Drawing Component Templates

DwgSynchTemplatesCmd.SynchTemplates

Repairs a drawing component that has become corrupted by synchronizing it with a different, uncorrupted drawing component. This command requires that the source component is the same type as the corrupted component, the source component must have a template, and that the source component cannot be corrupted. Also, the number of views on the source component must be the same as the number of views on the corrupted component. The names of the views on the source component must match the view names of the corrupted component.

Verify P&ID Integrity

SP3DDisplayPIDService.
VerifyPIDCmd

Validates the internal connections between objects on a P&ID and objects in the Model database. This command is useful when there is a problem displaying a P&ID or selecting objects on a P&ID. The command provides some basic troubleshooting statistics: Number of design basis objects, number of 3D objects (correlated), number of P&ID objects, number of deleted P&ID OIDs, and number of duplicate OIDs.

Custom Commands Dialog Box

Add Custom Command Dialog Box

Edit Custom Command Dialog Box

What do you want to do?