Create a filter-based report - Intergraph Smart 3D - Help

Intergraph Smart 3D Reports

PPMProduct
Intergraph Smart 3D
PPMCategory_custom
Help
SPFVersion_custom
7.1 (2018 R1)
Version_SThreeD_Custom
11 (2016)

Use the following workflow to create a report without using a SQL query. The query is creating using filters and object properties.

This workflow can only be performed in the Drawings and Reports task. It cannot be used by Tools > Drawing Console command available in other tasks.

Create a Report Component

  1. Right-click the drawing root in the Management Console and select New > More to open the Add Component Dialog.

  2. Select Folder on the General tab of the Add Component Dialog.

  3. Click OK to create the new folder.

  4. Right-click the folder, and select the Rename Command. Give the folder the needed name.

  5. Right-click the folder and select New....

    The Add Component dialog box opens.

  6. Select the General tab of the Add Component dialog box.

  7. Select the Spreadsheet Reports package and click OK.

    The New Spreadsheet Reports component opens in the Management Console.

  8. Right-click the component in the Management Console and select Rename. Give the component the needed name.

Create the Report

  1. Right-click the component and select Create Report.

    The Select Report Template dialog box opens. For more information, see Select Report Template Dialog Box.

  2. In the Reports > Base Templates folder, select Report Template (No Query). Click OK.

    A report also displays in the Detail View. The report is out-of-date and a red X icon is superimposed on the icon.

  3. Right-click the report and select Edit Template.

    The Report Template Editor opens within the detail view. For more information, see Report Template Editor.

Create a New Filter Query

  1. Click Tools > Add Query.

    The Add Report Query dialog box opens.

  2. In the Reports > Components for Reports > Query folder, select Filter Based Query. Click OK.

  3. In the Add Query dialog box, type a value for Enter the name of the query for the report. This is the name of the query.

  4. Click OK.

    The Select Filter dialog box opens.

    For more information, see Select Filter Dialog Box in any of the Drawings user's guides, available from Help > Printable Guides.

  5. Select or modify an existing filter, or create a new filter. For more information, see the Filter Properties Dialog Box in the Common User's Guide.

  6. Click OK.

    The Report Template Editor now has a Query tab. The query name displays in the Name field and the selected filter displays in the Filter field. Name is also defined as the first Property Name in the grid. For more information, see Query Tab (Report Template Editor Dialog Box).

Define Properties of Model Objects

Perform these steps if your query needs refinements to the results provided by the filter.

  1. Select the Property Name field on the second line of the grid.

  2. Click Add .

    The Select Properties dialog box opens. For more information, see Select Properties Dialog Box in the Common User's Guide.

  3. In Object type used as the basis for the property identification select More.

    The Select Object Type dialog box opens.

  4. Select one or more object types needed for your report. For more information, see Select Object Type Dialog Box in the Common User's Guide

  5. Select a value for Relationship.

    The most commonly used value is Direct Property of Object Type.

  6. If needed, select values for Related object type and Display properties in this category.

  7. In Select one or more properties, select the needed property. Click OK.

    The property displays in the grid.

  8. If needed, type a different value for Alias Name.

  9. Repeat these steps for each needed property.

Run the Filter-based Query

  1. in the Edit Template dialog box, click Execute Query .

  2. Report results display in a new grid at the bottom of the Query tab of the Report Template Editor.

Format the Report

  1. On the Formatting tab, click Design Layout .

    The Design Layout and Report Template (No Query).xls windows open in Microsoft Excel. For more information, see Formatting Tab (Report Template Editor Dialog Box) and Design Layout.

  2. In the Design Layout window, right-click Report at the top of the hierarchy, and select Properties.

  3. The Report Properties of Sheet 1 dialog box opens. For more information, see Report Properties of <SheetName> Dialog Box.

  4. In the Report Items panel, select the filter in Report Items Available.

  5. Click Add. The filter moves to Report Items on Sheet. Click OK.

  6. The filter displays in the hierarchy of the Design Layout window under Report \ Report Items \ [Filter Name]. The properties defined for the filter display in Report \ Report Items \ [Filter Name] \ Attributes.

  7. Drag each property from the Design Layout window to the needed column in the Report Template (No Query).xls window.

    Drag the properties below the heading rows. These rows have borders and shading.

  8. Add text and reformat the heading rows as needed.

  9. Click File > Save.

  10. Click File > Exit to close Microsoft Excel.

  11. Click Yes to save the report formatting to Report Template (No Query).xls.

Save Report Template Files

  1. In the Drawings and Reports task, click File > Save Report Template As.

    The Save Templates As dialog box opens. For more information, see Save Report Template As (File Menu).

  2. The report template consists of a series of files (rtp, rqe, rfm, rfp, xls, rdy). For each file, select the file, click Rename and type the new name.

    • Filename changes to match the Name.

    • The query name of the rqe file cannot be changed, but its file name can be changed. Click Yes in the dialog box to change only the file name.

  3. Click Save.

  4. In the Management Console, select the reports component.

  5. Click Yes to save the report template.

Update and View the Report

  1. In the Detail View, right-click the report and select Update Now.

    A green check is superimposed on the report icon after the update completes.

  2. Right-click the report and select Open.

    The report opens in Microsoft Excel.

See Also

Run Report Command in Common User's Guide
Report Templates
Report Queries to Extract Data
Appendix: Report Descriptions
Save Report Template As (File Menu)
Save Report Template (File Menu)
Define User Item Dialog Box