Boundary List Dialog - Intergraph Smart 3D - Help

Intergraph Smart 3D Molded Forms

PPMProduct
Intergraph Smart 3D
PPMCategory_custom
Help
Version_SThreeD_Custom
11 (2016)

Displays the boundaries for the object that you are placing:

  • Model objects, such as plate systems and profile systems. You can also bound profiles by plate edges, other profiles, and seams.

  • Reference planes and other plane definitions.

  • Sketched boundary curves created using the Sketch 2D option on a supported ribbon. Boundary curves are prefixed with SketchGroup_.

  • A standalone plane created during a copy, move, or mirror operation when a boundary was not included in the operation. You can replace the standalone plane with a new boundary.

Open this dialog by clicking Boundary List on the command ribbon during the boundary definition step.

You can define the Highlight color on the Tools > Options Command > Colors Tab (Options Dialog).

Preview Type

Each selected boundary highlights in the graphic view according to the selected preview type. This option applies only to plates.

In the following examples, two plate systems, a reference plane, and a sketched boundary are the selected boundaries of the vertical plate.

Bounding Objects

Highlights the selected boundary object as an outline. Reference planes display as translucent shaded planes.

Bounding Geometry

Highlights the internal boundary geometry used by the software. The internal geometry is typically an unlimited length line for model objects and reference plane boundaries.

Edges

Highlights edges of the bounded object where the bounded object intersects with the selected boundary.

For Bounding Objects and Bounding Geometry, the complete sketched boundary curve geometry displays as drawn in Sketch 2D , as shown in the following example.

Add

Specifies a new boundary. You can select a boundary in the graphic view or the Workspace Explorer.

  • You can also type the boundary name and an optional offset value in the Name box or the Offset box, and then press TAB or ENTER.

  • Invalid text displays with a gray background in the Name box or the Offset box.

  • A profile has a maximum of two boundaries, but a plate edge boundary displays on two rows of the boundary list. Both the plate edge and the edge's parent plate system display in the list.

  • The boundary list holds a maximum of two items. If you click Add with two items already in the list, Smart 3D removes the first list item, and then adds the new item to the bottom of the list.

  • When you select a boundary in the list and Smart 3D defines the landing curve, the software highlights the end point of the profile with a red star.

  • If you modify a row with a new boundary or offset, Smart 3D maintains the existing relationships of the previous boundary. This maintains manual end cuts, corner features, and manual logical connections. Manual logical connections go on the To Do List Dialog if the other profile no longer touches the modified profile.

Remove

Removes the selected boundary from the list.

  • Deleting a boundary curve from the 2D environment (Sketch 2D on the main command ribbon) also removes it from the Boundary List dialog.

  • Do not use the DELETE key to remove boundaries. DELETE removes sketched boundaries but does not remove bounding reference planes or reference objects.

Clear All

Removes all boundaries from the list.

/ Disconnect

Removes the relationships of a boundary to its definition method. When you disconnect a boundary, it becomes a standalone plane. This option is active by default for a standalone plane created during a copy, move, or mirror operation. After disconnecting a boundary, you must select a replacement boundary in the graphic view or the Workspace Explorer.

Extend Sketch Boundary in Graphic View

Extends a sketched boundary to a point in space or to another element selected in the graphic view. This option is available when you select a sketched boundary (with a name prefixed with SketchGroup_).

Name

Specifies the name of a boundary.

Offset

Specifies an offset distance from the boundary. You can type the following formats for offset values:

  • Offset distance without units.

Example: 5, when default units are millimeters (mm). The software converts the distance to 5 mm.

  • Offset distance with units. The value converts to the default units.

Example: 5 m, when default units are millimeters (mm). The software converts the distance to 5000 mm.

  • Coordinate System: Frame plus or minus an offset distance.

Example (when the model has multiple coordinate systems): CS_0:F20 + 1.5 m

Example (when the model has one coordinate system): F20 + 1.5 m

Invalid text displays with a gray background in the Name box or the Offset box.

Apply

Displays a preview of the boundaries in the graphic view. This option applies only to plates.

Gaps between boundaries display with a glyph.

The glyph uses the Handle color defined in Tools > Options Command > Colors Tab (Options Dialog).

OK

Closes the dialog and saves the boundary changes. To cancel boundary changes, you can click OK and then exit the parent command without clicking Finish. You can also select the northwest arrow to close the Boundary List dialog without saving the changes.