Add an Add-on View Style to an Existing Ruleset View Style - Intergraph Smart 3D - Reference Data

Intergraph Smart 3D Drawings and Reports Reference Data

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Reference Data
Version_S3D
12.1(2019)

The following procedure steps you through adding an add-on rule set view style to a primary rule set view style.

  1. Select Tools > Define View Style.

    The Define View Style dialog box opens.

  2. Select Ruleset Styles as the View Style Type.

  3. Select the view style to which you want to add the add-on rule set view style.

  4. Click Properties .

    The Edit Ruleset View Style dialog box displays, showing the definition for the selected rule set view style.

  5. On the AddOns tab, click the browse button in an AddOns table row.

    The Select AddOn dialog box displays, showing a list of rule set styles.

  6. Select an add-on rule set view style, and click OK.

  7. In the Edit Ruleset View Style dialog box, click OK to save the changes to the view style.

  8. In the Define View Style dialog box, click Close.

Add-ons can also be controlled by individual source actions. For more information, see Apply an Add-on to a Source Action.

In the example below, the AddOn - Grid Axis view style adds rulers based on a coordinate system associated with the drawing view. All planes from the coordinate system are drawn as well.

Without AddOn - Grid Axis:

With AddOn - Grid Axis:

See Also

Add-on Ruleset View Styles
Define View Style Command (Tools Menu)
Edit Ruleset View Style Dialog Box
AddOns Tab (Edit Ruleset View Style Dialog Box)