General Tab (Edit Ruleset View Style Dialog Box) - Intergraph Smart 3D - Reference Data

Intergraph Smart 3D Drawings and Reports Reference Data

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Reference Data
Version_S3D
12.1(2019)

Specifies miscellaneous rules used within the marine mode rule set view style.

Preview View Style

Specifies the view style used for preview geometry after a view is placed, but before generating an update of the view. Select More to open the Select View Rule dialog box and select the needed view style.

Added Object Color

Specifies the geometry color for added objects used by the Update view generation mode. The default value is <Default from View Style>.

Modified Object Color

Specifies the geometry color for modified objects used by the Update view generation mode. The default value is <Default from View Style>.

Deleted Object Color

Specifies the geometry color for deleted objects used by the Update view generation mode. The default value is <Not Tracked>.

Associate Objects to View Command

Specifies which associate ribbon the software displays when associating objects to a view. Select one of the following:

  • Default (List-Based) - Displays a list-based Ruleset View Ribbon.

  • Default (Step-Based) - Displays a step-based Ruleset View Ribbon. This ribbon provides the most flexibility, including the ability to orient the drawing view by the local coordinate system of a part selected in the graphic view.

  • Expansion - Displays the Expansion View Ribbon for use with expansion drawings. We recommend using this ribbon when working with expansion view styles because it allows you to select expansion-specific inputs such as cutting axis, base plane, offset plane, and so forth.

  • Generic - Displays a step-based Ruleset View Ribbon designed specifically for the generic rule set.

For more information about these ribbons, see Associate Objects to View Command in the Orthographic Drawings User's Guide.

Intersection Edges

Creates lines where surfaces intersect each other. Select Off to omit all surface intersection lines. Select Low Resolution to draw all lines except b-splines between intersecting surfaces. Select High Resolution to draw all lines including b-splines between intersecting surfaces. For example, changing from Off to High Resolution would produce the following effect for your graphics:

High Resolution draws the most detail but increases view generation time.

Preserve Z Order

Maintains the three-dimensional order of resymbolized graphics. This setting overrides the top-down ordering in the graphic rules of a view style. A cleaner-looking drawing results if this option is selected. Select Yes to turn on the option. For example, pipe gaps display according to their layering in the 3D model:

Projector

Defines the scaling method used for a manufacturing sketch. Select one of the following:

  • Mfg Sketch - Not to Scale - Fits the sketch and all information into a fixed-size view. All geometry, symbols, and annotations are clearly displayed, but the geometry is not to scale. This is the typical selection for fixed-size manufacturing sketches.

  • Mfg Sketch - To Scale - Draws geometry to scale. Geometry, symbol, and annotation display is similar to the Part Monitor in the Structural Manufacturing task.

Additional View Inputs

Defines the .xml file from which to import additional view properties for the selected view style. The view properties from the selected .xml file display on the View tab in the Drawing View Properties dialog box. For more information, see Drawing View Properties Dialog Box (Place View Command) - Steel Order Drawings in the Smart 3D Orthographic Drawings User's Guide.

  • Additional View Inputs is only supported for generic rule sets.

  • To display the additional view properties, the value for the IsShowOnPropertyPage attribute in the .xml file must be 1.

  • You can either select a delivered .xml file, or create a new .xml file. You can also edit the delivered Steel Order Extensions.xml file, located in the [Reference Data Folder]\SharedContent\Drawings\Catalog\Rules\DBRRules\AdditionalViewInputs folder, to add or remove view properties.

See Also

Define View Style Dialog Box
Edit Ruleset View Style Dialog Box
Define View Style Command (Tools Menu)
Create a Rule Set View Style