Create Line Styles to Use in Drawing View Styles - Intergraph Smart 3D - Reference Data

Intergraph Smart 3D Drawings and Reports Reference Data

PPMProduct
Intergraph Smart 3D
PPMCategory_custom
Reference Data
Version_S3D
12.1(2019)

The following steps show you how to create new line styles in the SmartSketch Drawing Editor and implement them in drawing view styles.

In plant mode, the lines styles used by drawing view styles are stored in the Styles.sha file in the [Reference Data Folder]\SharedContent\Drawings\Catalog\templates\ folder. For drawings by rule in marine mode and material handling mode, the lines styles used by drawing view styles are stored in the ISStyles.sha file in the [Reference Data Folder]\SharedContent\Drawings\Catalog\templates\ folder.

To add line styles to this file, you need write permission to the file, as it is shared. If you do not have write permission to the file, you will not be able to save changes you make to the file. Contact your system administrator if you require write access to the file.

Create a New Line Style

For more information on commands available in SmartSketch Drawing Editor, see the SmartSketch Drawing Editor Help.

  1. Open the Styles.sha file (plant mode) or the ISStyles.sha file (marine mode or material handling mode):

    • Open SmartSketch Drawing Editor from the Start menu.

    • Using File > Open, navigate to the location of the Styles.sha file or the ISStyles.sha file, and open it.

  2. In SmartSketch Drawing Editor, select Format > Style. The Style dialog box displays.

  3. Change the Style type to Line, then click New to create a new line style.

  4. On the New Line Style dialog box, name the new line style. For example, create a new line style called AAA_Normal Dark Red.

  5. In the Based on field, select a line style on which to base the new line style. For this example, the base style is None, which applies the style settings Color=Black, Weight=0.35 mm, Type=Dash Dot to the new line style.

  6. Go to the General tab. Change the Color setting to Dk Red. Set the Width and Type properties as needed.

  7. Click OK to save the changes. The new line style displays in the Styles list on the Styles dialog box. Click Close to exit the dialog box.

  8. Select File > Save to save the Styles.sha file or the ISStyles.sha file with the new line style.

  9. Exit SmartSketch Drawing Editor.

Implement a New Line Style in a Drawing View Style

For more information on creating view styles, see Define View Style Command (Tools Menu).

  1. In the Drawings and Reports task, select Tools > Define View Style. The Define View Style dialog box displays.

  2. Select an existing view style, and click Properties . This example uses the orthographic Civil Plan view style. The dialog displayed depends on the type of view style selected. If you select an orthographic view style, the View Style Properties dialog box displays. If you are changing a key plan view style, the Key Plan Style dialog box displays. If you are modifying a marine mode rule set view style, the Edit Ruleset View Style dialog box displays.

  3. With any view style type, you want to modify the Graphic Rule definition to use the new line style. Select More in the Graphic Rule box to display the Select Graphic Rule dialog box.

  4. Select an existing graphic rule from the list and click Properties to display the Graphic Rule - VHL dialog box. You can select the Visible Line Style property, for example, and select your new line style in the Value box. Click OK to modify the existing graphic rule, or you can change the name in the Rule name field to save the changes to a new graphic rule name. If you change the name, a confirmation dialog displays so that you can verify the graphic rule action.

  5. Use the modified or new graphic rule in the view style definition, and click OK to close the dialog boxes. You can save the changes to the existing view style or change the name of the view style. A confirmation dialog box displays so you can verify the view style action.

  6. Use the modified or new view style to create drawings and verify the appearance of the new line style.

See Also

View Style Properties Dialog Box
Key Plan Style Dialog Box
Edit Ruleset View Style Dialog Box
Define View Style Command (Tools Menu)