Define View Style Command (Tools Menu) - Intergraph Smart 3D - Reference Data

Intergraph Smart 3D Drawings and Reports Reference Data

PPMProduct
Intergraph Smart 3D
PPMCategory_custom
Reference Data
Version_SThreeD_Custom
12.1 (2019)

Defines drawing view and key plan styles for drawings and MicroStation 3D DGN documents and defines rule set view styles to use with marine mode drawings by rule components and packages. This command displays the Define View Style dialog box, which lists the available styles.

Each drawing view and MicroStation 3D DGN document in the software has an associated view style and can have a key plan style. A view style contains several rules for filtering, labeling, and creating the graphics in the output document. The key plan style specifies the rules used to define the appearance of the key plan associated to a drawing view.

Rule set view styles define the style information for drawings created using a marine mode drawings by rule component.

Define View Style Dialog Box

Defining Filters for View Styles

You can set up the filters for styles by using File > Define Workspace or Tools > Select by Filter in any 3D task. One way to organize the drawing filters is by discipline, such as Piping, Equipment, or Structure. You can also define filters within the View Style Properties dialog box by selecting More in the Filter dropdown.

For more information, see Select Filter Dialog Box in the Common User's Guide.

Defining View Styles for Drawing Views

For orthographic drawings, you can create and edit view styles using Tools > Define View Style. For Isogen isometric drawings, you can modify drawing output using the Isometric Style Options Browser dialog box.

The software comes with default view styles for a number of drawing types. These view styles can be used as delivered, or copied and modified to suit your needs.

You can change the order of the rows on the View Style Properties dialog box by selecting a row and then clicking the up and down arrows on the left side of the dialog box. The software applies the graphic rules in a top-down manner. If an object finds its match in several filters, the last graphic rule applied (the bottommost style) overrides any preceding graphic rules. Label rules and dimension rules accumulate.

Defining Styles for Key Plans

The Tools > Define View Style command also allows you to create and maintain styles for key plans you place within a drawing. The key plan style uses an existing drawing view style to define the appearance of the key plan. You can create three different types of key plan styles: One Volume with Model View, Natural Volumes Only, and Normalized Volumes Only.

Defining Marine Rule Set View Styles

Within a marine mode drawings by rule component or package, you can have multiple view types. Each view type can have many view styles. You create the view styles from valid rule sets available in the catalog. You can create multiple view styles from a single rule set. You then specify the view style to use when creating a drawing view of a particular view type within a drawing by rule component or package.

With regard to the graphic rules specified as part of the view style properties, the software honors only the last aspect applied.

See Also

Isometric Drawing Styles
Create a Ruleset View Style