Apply Grid Labels to Elevation Views - Intergraph Smart 3D - Reference Data

Intergraph Smart 3D Drawings and Reports Reference Data

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Reference Data
Version_S3D
12.1(2019)

The following procedure describes how to apply grid labels to elevation views on drawings. Custom rules are required along with filters for grid plane objects.

This procedure creates separate view styles for Elevation views. You then create Elevation view drawing type packages using the appropriate view styles. For more information, see Save Package Command, found in any of the Smart 3D Drawings user's guides available from Help > Printable Guides.

The example below uses the GridLinesDrawingWrapperEntity.dll custom rule to resymbolize the grid plane as a set of lines. The lines draw at all perpendicular plane locations and extend along the elevation plane from (lowest Z-1)m to (highest Z+1)m of the coordinate system to which the grid plane belongs. For example, if the coordinate system has X=0,10,20, Y=0,5,10 and EL=0,10, then for the grid plane at X=0, there will be three lines:

  • Y=0 from Z-1 to Z+11

  • Y=5 from Z-1 to Z+11

  • Y=10 from Z-1 to Z+11

Check for the Required Filters

If the catalog you are using does not have filters for Grid Plane Elevation, you need to create them. You need one for Elevations looking North/South.

Check the catalog for the filters. If you are using the default filters, these filters are delivered under Catalog Filters > SP3D Object Filters > Grid Systems.

Create the Required Filters

If the Grid Plane Elevation filters do not exist, you can create them. For more information on creating filters, see the Common User's Guide.

  1. In the Common task, use File > Define Workspace to create two new filters. On the Define Workspace dialog box, select Create new filter in the Filter box. The New Filter Properties dialog box displays.

  2. Go to the Object Type tab and select Grid Systems. Expand Grid Systems and select Grid Plane.

  3. Go to the Properties tab to further restrict the filter. For example, select Grid Planes and restrict to Axis = X for the Elevation filter. Select More in the Property box. The Select Properties dialog box displays so that you can specify the property definition for the Grid Plane object. Click OK to return to the Properties tab to set the value for the selected property. Refer to the graphic below for more information.

  4. Click OK to save the new filter definitions.

Create an Orthographic Drawing View Style

After checking to make sure you have the required filters or creating new filters, you need to create a view style that uses the filters to create the grid labels on your drawings. Go to the Drawings and Reports task to perform the steps below.

  1. Select Tools > Define View Style. The Define View Style dialog box displays. For more information, see Define View Style Dialog Box.

  2. In the View Style Type box, select a drawing view style type.

  3. Click New Style to create a new view style in the current folder. If you want to create a new folder for the view style, click New Folder first, then create the new style in the new folder. For example, you could create a view style called Elevation Grid Bubbles.

    You can use Rename to change the name of the new folder or style.

  4. Select the new style, and click Properties to open the View Style Properties dialog box. For more information, see View Style Properties Dialog Box.

  5. In the Graphic Preparation Rule box, select More. The Select Custom Rule dialog box displays.

  6. Click New to create a new graphic rule. The Custom Graphic Rule dialog box displays.

  7. Select the Grid Plane Elevation filter by selecting More in the Filter Name dropdown.

  8. Apply the GridLinesDrawingWrapperEntity.dll custom rule to resymbolize the vertical grid planes as lines.

  9. Click OK on the Custom Graphic Rule dialog box.

  10. On the Select Custom Rule dialog box, select the new rule, and click OK to return to the View Style Properties dialog box.

  11. Specify a graphic rule to apply color or style to the graphics in the drawing.

    You can use the Invisible style to prevent the lines for Grid Planes from displaying. The software labels them even when invisible.

  12. Apply a label rule that returns the name as its value.

    You can copy one of the delivered Grid labels and its supporting files in the [Reference Data Folder]\SharedContent\Drawings\Catalog\Labels\Templates folder and the [Reference Data Folder]\SharedContent\Drawings\Catalog\Rules\LabelRules folder. Rename the new label and substitute one of the delivered name label .rqe files for the new labels query.

  13. After defining the drawing view style, click OK to save the settings. The view style is now ready to use with drawings.

This example uses columns and beams to give the results of the view style application and meaning. The row referencing Grid Plane Elevations is the only required row. In a drawing using the new view style, the Grid Planes are blue based on the settings from the view style:

Some modeling situations have intersections that cause unwanted Grid Planes to display and be labeled. You may need to edit the drawing document and delete unwanted labels. Be sure to save changes to make to the drawing document so that subsequent updates are remembered.

See Also

Create an Orthographic Drawing View Style
Define View Style Command (Tools Menu)
Create or Edit a Graphic Preparation Rule