Composed Drawings - Intergraph Smart 3D - Reference Data

Intergraph Smart 3D Drawings and Reports Reference Data

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Reference Data
Version_S3D
10.1(2014R1)

Composed drawings are orthographic drawings created in a 3D task, such as Common, through the Drawing Console. The composed drawing component manages the composed drawings you create. Composed drawings are flexible, allowing you to have views that are managed by a drawing region and to associate the views to volumes and other views.

In 3D modeling tasks such as Common, you can use the Tools > Drawing Console command to create a composed drawing component and the drawings associated with it. In the Drawings and Reports task, you can create the composed drawing component, but you must use the 3D modeling tasks to associate the drawing to objects in the model.

  1. In the Drawings and Reports task, use the Tools > Define Layout Style command to create layout styles you need for your composed drawing regions, then use the layout styles when you create your layout templates with the Tools > Edit Layout Template command.

  2. Create a folder for the drawing component in the Management Console, or go to a 3D task and use Tools > Drawing Console to create the component.

  3. In the 3D modeling task, use the Drawing Console to create new composed drawings. Right-click the component, and select New Drawing. For more information, see New Drawing in the Orthographic Drawings User's Guide, available from Help > Printable Guides. You can also use Edit on the shortcut menu to view or modify existing composed drawings. You can select Tools > Snapshot View to add snapshots of the model to composed drawings. For additional information, see the Common User's Guide available from Help > Printable Guides.

  4. When the composed drawing is open in the SmartSketch Drawing Editor, you can add views, associate views to volumes or other views, remove view associations, add dependent report views, and modify the layout of the drawing sheet. For more information, see Create a New Composed Drawing in the Orthographic Drawings User's Guide. For information on the Drawings Compose toolbar in plant mode, see Working with 3D Task Drawings in the SmartSketch Drawing Editor Help. For information on the Drawings Compose Toolbar in marine mode, see Working with Marine 3D Drawings in the SmartSketch Drawing Editor Help.

  5. After saving the drawing in SmartSketch Drawing Editor, return to the Drawing Console to do additional editing, update the drawing, and revise and publish the drawing. After the composed drawing is created, it is just like any other drawing document and can be managed in the Drawings and Reports task. For information on the 2D commands available for editing, see the SmartSketch Drawing Editor Help.

If the drawing document you are looking at in the Detail View has a yellow icon (for example: ), the drawing document is a version 6.1 legacy Snapshot drawing. You should use the Tools > Convert Legacy Snapshots command to convert this document to a Composed Drawing for use in the current version of the software. If you do not convert the legacy snapshot drawing, you cannot perform edit operations on the drawing, including update, revise, and publish. For more information, see Convert Legacy Snapshots in the Orthographic Drawings User's Guide.

Drawing Regions and Drawing Views

A region is a container that manages drawing views. The layout style associated with the region dictates the order and placement of the managed drawing views. Drawing views are associated with objects, volumes, or other drawing views. You place regions and views on a composed drawing when it is open in SmartSketch Drawing Editor. For more information on placing regions and views, see the SmartSketch Drawing Editor Help.

Regions and drawing views behave as follows:

  • You can create a drawing view outside a region, but this makes the drawing view an "unmanaged view," meaning the properties of the region do not impact the drawing view. However, if a view is inside a region or touching a region, the region manages the drawing view. When you update the drawing, the software associates the drawing view with the region and updates it based on the applied region layout style.

  • If a region refuses to accept a drawing view (for example, if the region is defined for three views, and you are attempting to add a fourth view), the drawing view is added as an unmanaged view, just outside and to the upper left of the region. If another region occupies this space in the drawing area, the unmanaged view is placed as close to the original region as possible.

  • If a drawing view "straddles" two or more regions, the region that contains more of the drawing view manages it. If the drawing view equally straddles two or more regions, the software uses the first drawing view point to measure distance and determine which region manages the drawing view.

  • If a region contained a drawing view and the drawing view properties make it ineligible for the region, the software removes the drawing view from the region automatically and places it in the upper left of the drawing area, outside of other regions.

Layout Templates and Layout Styles

Composed drawings use layout templates and layout styles to assist you in creating reusable drawings. The software combines layout templates with drawing borders to create composed drawings. Layouts also use regions as containers to manage drawing views. You also define a layout style associated with the region. The layout style dictates the order and placement of the managed drawing views. For more information on defining layout styles, see Define Layout Style Command (Tools Menu). For additional information on editing layout templates, see Edit Layout Template Command (Tools Menu).

Drawing Borders

When you create a composed drawing in a 3D task, you specify a border template to use with the drawing. After the drawing is created, you can switch the border associated with the drawing using the Switch Border command on the shortcut menu of the drawing. For more information, see Switch Border in the Orthographic Drawings User's Guide.