Select Filter Dialog Box - Intergraph Smart 3D - Reference Data

Intergraph Smart 3D Drawings and Reports Reference Data

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Reference Data
Version_S3D
10.1(2014R1)

Creates, edits, deletes, and selects filters for use with the Define Workspace, Surface Style Rules, and other Select by Filter commands, including Project Management's Model Data Reuse (MDR), Drawings View Styles, and Reports commands that require runtime filter selection. You can access this dialog box in several ways as listed.

  • Select File > Define Workspace, and select the More option in the Filter box.

  • Select Format > Surface Style Rules, click New or Modify, and then select the More option in the Filter box.

  • Select Tools > Select by Filter.

The tree view displays the following types of filters:

  • Catalog Filters - These filters are used similarly to reference data in the Catalog. For example, a catalog filter could apply to company-wide operations. Your administrator can define Company_Filter_1, Company_Filter_2, and so forth.

  • Plant Filters (for plant mode) or Ship Filters (for marine mode) - These filters are available to everyone assigned to a specific model database. There are delivered catalog filters to query on the different types of plant mode or marine mode objects. You must have the appropriate privileges to create, edit, or delete these filters.

  • My Filters - These are personal filters that you create and place in the My Filters folder. They are visible only to you, the owner. You cannot see the personal filters of others, and they cannot see your personal filters. Select a filter from one of the listed filters, or create a new filter to meet your specific requirements.

New Folder

Creates a new folder.

New Filter (Simple or Asking)

Displays the New Filter Properties dialog box so you can create a new filter. Asking filters allow you to specify the parameters of the search. An asking filter has built-in functionality to ask for values (with boxes that you are required to record). The values apply to properties that you have already designated you will supply when the filter runs. Asking filters are portable between models.

Model Data Reuse (MDR) does not support asking filters. The only valid filter types for an MDR transaction are System, Permission Group, Object Type, Volume and Properties. You can define the filter on any one of these tabs or in a combination using multiple tabs.

New Compound Filter

Displays the New Compound Filter Properties dialog box, which you use to create a new compound filter containing the Or, And, or Not operators. Compound filters are not supported for MDR.

New SQL Filter

Displays the New SQL Filter Properties dialog box, in which you can type the text of an SQL query. SQL filters are not supported for MDR

Delete

Removes a filter or folder from the Select Filter list. If you delete a folder, the software also deletes its contents.

Rename

Changes the name of an existing filter or folder from the Select Filter list.

Properties

Displays the Filter Properties dialog box so you can select the properties that determine your filter search criteria.

  • If this dialog box is activated from the Select by Filter command, you can select multiple filters on this dialog box. Hold CTRL or SHIFT, and click each filter. When you click OK, all objects that fit the selected filters are selected.

  • If this dialog box is activated from the Select by Filter command, it clears the select set before adding objects to the select set.

See Also

Select by Filter
Select objects by filter