Accuracy of MicroStation Data During Import - SmartSketch - Help

SmartSketch Help

PPMProductFamily
Engineering and Schematics
PPMProduct
SmartSketch
PPMCategory
Help
Version_SPEM_custom
8.0.0
Version_SSK
10.0(2018)

When you translate MicroStation data into SmartSketch, you are concerned with either Visual fidelity, Data fidelity, or both.

To use this functionality, you must install the Translators option.

Visual Fidelity

Visual fidelity is a phrase used to describe the visual accuracy of a picture after translation. SmartSketch preserves the visual accuracy of a MicroStation file by providing support for the following areas:

Colors

MicroStation and SmartSketch use the same format for colors, and they each store them in the industry standard red, green, blue (RGB) format. During import, MicroStation colors are automatically translated to the corresponding RGB values in SmartSketch, resulting in a perfect color match.

Widths

SmartSketch provides a default set of line widths that corresponds to standard metric pencil leads: .13 mm, .18 mm, .25 mm, .35 mm, .5 mm, .7 mm, 1.0 mm, 1.4 mm, and 2.0 mm. When you open a MicroStation document, a default mapping determines which SmartSketch line width is assigned to go with which MicroStation weight. You can change any of the default mappings to define your own mapping with the Line Width tab of the MicroStation Import Options dialog box (accessed through the Foreign Data Tab (Options Dialog Box) after you select Options on the Tools menu).

Linestyles

The core MicroStation linestyles 0-7 default to matching SmartSketch linestyles, unless they are mapped on the Linestyle tab of the MicroStation Import Options dialog box. MicroStation User Defined Line Styles (UDLS) are supported directly. If you use the Style Resources dialog box, you can attach a MicroStation linestyle resource (*.RSC) file as a resource for linestyles to use in a document.

Patterns

Non-associative MicroStation patterns are imported as groups. Associative patterns are not translated into SmartSketch.

Font Styles

SmartSketch supports the system TrueType fonts delivered with Windows and supplies additional ANSI and ISO TrueType™ engineering fonts. SmartSketch also supports MicroStation fonts. When you open a .DGN document, SmartSketch provides a default mapping to determine which TrueType font is assigned to which MicroStation font. You can change to this mapping to define your own mapping. You can change the mapping with Options on the Tools menu. On the File Locations tab, you can set the paths to the font resources by double-clicking on Fonts 1, 2, and 3.

References

MicroStation references are imported as SmartSketch reference files, which use the automatic defaults or same options for configuring how color, weights, line styles, patterns, and fonts are handled for visual accuracy.

Configuring the Fit to Sheet Feature

SmartSketch automatically calculates the sheet scale when you import MicroStation documents so that the range of graphics automatically fits within the lower left-hand corner of the drawing sheet. If you do not want the sheet scale automatically calculated, then you must uncheck the Fit imported data to active sheet check box on the MicroStation Import Options dialog box.

You can create a template for calculating sheet scale at the scale you want and insert a MicroStation document to base the template on. On the Sheet Setup dialog box, you set the Drawing Scale and Paper Units that you want.

Using MicroStation Fonts and Styles in a SmartSketch Document

If you want to make line styles from MicroStation resource files available in a SmartSketch document, you can reference the styles with style resource documents. You can reference a MicroStation .RSC file from the active template or document by clicking Resources on the Styles dialog box.

When you attach a .RSC file from the current document or template, the styles in the resource document are added to the Style dropdown list on the ribbon for the active document.

MicroStation resource files for line styles are treated as a document setting. If you want to have all documents that are created by importing use the same styles, you must create an .IGR template with those styles attached. You then specify the .IGR template as the template to use during import of MicroStation documents.

Data Fidelity

Data fidelity is a phrase that describes how accurately the data is preserved when compared to its original form in the application that created it. SmartSketch preserves the data accuracy of a MicroStation file by providing equivalent element types with mapped entities to SmartSketch. SmartSketch also provides support for non-displayed data such as database linkages, units, and coordinates.

SmartSketch preserves data accuracy of a MicroStation file by providing support for the following areas:

Units

MicroStation files are determined by the master and sub-unit labels in the file.

  • If meaningful master units and sub-units are found, the resulting SmartSketch document has the closest matching units set on the Units tab of the Properties dialog box.

  • If no meaningful master units and sub-units are found, the File Units setting in the Import area of the Options dialog box is used to determine the units for translated or referenced MicroStation files.

Coordinates

MicroStation data is automatically positioned to matching coordinate positions when you translate the MicroStation files (click Open on the File menu). Referenced MicroStation file coordinate positions are determined by the settings on the Reference File tab on the Options dialog box.

You can use Coincident to import the data in its original coordinate position at a 1 to 1 scale.

Levels

MicroStation level numbers, names, or both are preserved as SmartSketch layer names, but the color and linetype settings (level symbology) are not. The color and linestyle settings apply directly to the resulting elements.

Within a SmartSketch document, there are an unlimited number of layers per sheet. When translating foreign files into SmartSketch, the levels in MicroStation keep the same names. The MicroStation Export Options dialog box provides a layer mapping table, due to the limit of 63 levels in MicroStation. You can access this dialog box with the Foreign Data tab after you select Options on the Tools menu.

Cells

When you translate a .DGN document, the default is to translate cells into symbols. You can change this default with Options on the Tools menu so that cells or blocks are embedded groups. This action translates cells and blocks into embedded symbols, or groups, in SmartSketch.

MicroStation Type 2 cells are imported into SmartSketch as a group. However, for MicroStation V8, the Import Cells2 as Symbols setting has been added to the itmstn.ini configuration file to define whether Type 2 cell headers are imported from MicroStation V8 files as symbols or groups. A group contains a dynamic attribute set that stores the name of the cell, its origin, and any other data characterizing the cell. There is, therefore, enough information stored in the group to reconstruct an element back into a cell to export in the future.

When you import a MicroStation document that has cells, a temporary folder is created in the Temp folder on your computer. The temporary folder contains the symbols that are embedded in the MicroStation document. By default, these symbols are deleted after the document is imported into the drawing sheet. You can change a setting in the delivered itmstn.ini configuration file to save the symbols instead. In Notepad, open the .ini file and change the line in the Options section: Delete Symbol Definitions = 0.

If there is no Delete Symbol Definitions setting in the .ini file, the software presumes the setting is set to 1; consequently, the symbols that are embedded into the drawing sheet are deleted after the MicroStation document is imported into the drawing sheet.

Cells with Attribute Data

When translating a .dgn document, the default is to translate all cells containing attribute data into symbols with Labels.

3D Data

All 3D data is flattened into a 2D view when you translate files using Open on the File menu. The 2D view orientation is determined by the Orientation setting in the Import area of the Options dialog box.

The following information is an entity-to-element map when you translate files using Open on the File menu.

MicroStation

SmartSketch

Line

Line

Linestring

Linestring

Bspline Curve

Bspline Curve

Shape

Linestring

Ellipse

Ellipse

Arc

Arc

Complex String

Complex String

Complex Shape

Complex String

Bspline Surface

Bspline Curve

Curve

Bspline Curve

Cone

Flattened wire frame

Surface

Group

Dimension

Dimension

Text

Text

Text Node

Text

Cell

Group

Shared Cell

Symbol (Shared Embed)

Multiline

Group

Point String

Points

Reference

Reference

Raster

Reference

Database Linkages

Dynamic Attribute set on the element

Tags

Dynamic Attribute set on the element

User Data

Dynamic Attribute set on the element

  • The Image Integrator option must be downloaded to support import of raster reference files.

  • MicroStation symbols with nested graphics, groups, and complex shapes (for example, rectangles) will not translate successfully into SmartSketch symbols.

  • None of the data that is part of the reference file can be deleted or altered using SmartSketch commands. However, if MicroStation software is installed on your computer, then you can click Open on the Shortcut menu over the reference file. This action opens the MicroStation reference file in the MicroStation application.

  • If you establish relationships between elements in the SmartSketch file and a reference file, the relationships will be removed if you change the position of elements in the source file and then update the reference file in SmartSketch.

  • If you change the inserted information (copied from MicroStation), the original information does not change.

See Also

Accuracy of MicroStation Data During Export