Add and Edit Attachments - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2018 R1 (7.1)
Version_SPR
13.x(2018)

Tools > Get External Data > Edit Attachments

Displays the Edit Attachments dialog box, which allows you to add, edit, or remove files associated with the selected object in the open project. Changes made using this command also alter the entries on the Get External Data menu. The file associations are saved to the Microsoft Access Get External Data database file for the project.

You can attach virtually any file type to an object in the project, such as Microsoft Word, Excel, and PowerPoint files; ASCII text files from Notepad or from the Smart Review Text window; MicroStation files, sound, animation, and Video Engine files. Executable files and their associated files must exist before you attach them.

If you select an object in the project that contains no property data and no attached data, the Edit Attachments button is disabled.

Attach External Data to a Project

  1. Select a graphic object in the model.

  2. Click Tools > Get External Data > Edit Attachments.

    Edit Attachments Dialog Box

  3. Click Insert on the Edit Attachments dialog box, and then select the label data attribute to which the external data will be attached.

  4. From the Type list, select the file type for the attached data file.

  5. On the Edit Filename / Argument dialog box, browse to the data file that you want to attach. Be sure the file that you select is of the same type you specified in the preceding step.

  6. Specify any arguments for the data file in the Arguments box, and then click OK. The Edit Attachments dialog box should now list the new attachment.

  7. Click OK on the Edit Attachments dialog box.

    The Tools > Get External Data menu shows the new attachment type:

  8. All objects in your drawing that contain the selected label data attribute (for example, Sequence) set to the same value (in this example, Pumps) have the same file attached (in this example, Richfield.jpg). Attachments also display in the Text window and Properties dialog box.

  • Attaching a file to an attribute value of one element automatically attaches the file to every element with the same attribute value.

  • Deleting a file that is attached to the attribute value of one element automatically deletes that attachment from every element with the same attribute value.

See Also

Attaching External Data
View Object Properties
Text Command