Troubleshooting: Viewing 3D Data - Intergraph Smart Review - Help

Intergraph Smart Review Help

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Help
SPFVersion_custom
2018 R1 (7.1)
Version_SPR
13.x(2018)

Problem

Solution

Cannot open a .vue file.

Generate a new Smart Review .vue file from the original model data set.Smart Review supports reading any .vue file produced by SmartPlant Review 05.00.01.02 or later. However, the .vue files produced in version 06.02.00.17 or later cannot be read by earlier released versions of SmartPlant Review.

Cannot view mixed PDS (DRI or VUE) and Smart 3D (VUE) files.

Attach the PDS project as a reference in Smart 3D, define the appropriate filters, and then use the Save as SmartPlant Review command. You will not get any PDS attributes, only the graphics.

Alternatively, save the data as a DGN from Smart 3D, attach the DGN files to a PDS project to produce a PDS DRI set, and open the DRI in Smart Review. In this case, you will not get Smart 3D attributes.

You can create a VUE file from the PDS DRI project. Combine it with the PDS DRV files, the Smart 3D VUE file and the Smart 3D attribute XML file in a SVF project in the same directory. In this case, you can see both PDS and Smart 3D attributes.

See the Smart 3D Orthographic Drawings User's Guide for more information.

The levels are not matching the ones that were edited in the discipline mapping file.

Smart Review reserves Level 1 for unmapped components. You can use "Find Level 1" to find all your unmapped components (if any). Thus, Smart Review increments by one the level numbers specified in the Smart 3D mapping file (either the legacy MapComponentsToDisciplines.txt file or the replacement MapClassIdToLevelDisciplines.txt file).

For example,  the P3DCable component is specified as Level 1 but displays inside Smart Review as Level 2. Change the P3DCable component to Level 0 to have it mapped to Level 1 in Smart Review.

Upgrading from a Smart Review version earlier that 7.x.

If you are upgrading from a Smart Review version earlier than 7.x, a message displays prompting you to select the configuration file used in your Smart 3D project.

Cannot see or find display sets containing DMRS linkages.

Display sets can be created based on linkages using the Linkage search criteria. New display sets created from selected objects default to the Linkage search criteria for all selection filters except Display Sets (Edit > Select Filter > Display Sets). When the filter is Display Sets and the selected objects in the Main view are display sets, then the Display Sets search criteria is used.

For VUE files produced by Smart 3D for non-native data, such as referenced MicroStation or PDMS data, the DMRS linkages may change on every reference. Therefore, we recommend that you use VUE files produced by Smart Interop Publisher for this data, and use other search criteria such as Data instead of Linkage, if possible.

Lines missing in the model.

When you open the model, select Keep lines and linestrings in the Create Project > Options tab.

Objects in my VUE file from SPRDirect are not at their expected locations in the Main view.

SPRDirect projects with both a Large Plant Monument point and an associated file transformation can require the View > Large Plant Monument command to be turned off so that Smart Review coordinate readouts match the Smart 3D coordinate readouts. For more information on transformation, see Information Tab (Edit File Position Dialog Box). For more information on the large plant monument origin, see the Large Plant Monument Command.

Object properties are available and visible but their relationship properties are missing in the Properties dialog box.

The SPRDirect method generates base object properties and currently does not generate object property relationships.  

When I transformed (moved or rotated) my project file using the Edit > File Position command, my display sets are no longer in the expected locations

Edit the reference origin point of your display sets to match that of the project file. The graphics contained in the project file are moved or rotated when you transform. However, the display set reference points are not changed, which means that your display set move and rotation can behave differently. You can change the previous display set reference origin points to be relative to the moved or new location of the graphics in the project file.