What's New - Intergraph Smart Review - Release Bulletin

Intergraph Smart Review Release Bulletin

PPMProduct
Intergraph Smart Review
PPMCategory_custom
Release Bulletin
Version_SPR
2020 (15.0)

Version 2020

  • Licensing support and new features for improved performance and usability

    • Smart Review exclusively requires the Intergraph Smart® Licensing software application. For more information on changing from the SmartPlant Licensing Manager (SPLM) application to Smart Licensing, see the Intergraph Smart Licensing Installation and Setup Guide.

    • The product Release Bulletin and Installation Guide reside on the new PPM documentation website. To access them, select Help > Printable Guides. You can check the PPM documentation website for the latest help updates.

    • You can now exit Smart Review from the Tablet mode navigation pane. See Exit (Tablet Mode).

    • Improvements have been made for a faster startup time.

    • Smart Review has improved rendering performance and reduced exported PDF and FBX files sizes. The Smart Review level of detail has been updated to render fewer triangles for the same stroking tolerance settings. You can also use the Stroking Tolerance command to adjust the rendering quality: see Stroking Tolerance Command.

    • You can import Wavefront 3D geometry .obj files with supporting material and texture files in your current model. When imported, Smart Review treats these 3D objects as display sets so that you can perform standard operations such as move, rotate, scale, measure, assign material, dim, show, hide, and set transparency. For more information, see Import OBJ Files.

    • A scale option has been added to the Edit Display Set Position dialog box so that you can resize selected display sets in addition to moving and rotating them. For more information, see Scale Tab (Edit Display Set Position Dialog Box).

    • Because Smart Review automatically saves project and attachments databases, the Save command has been removed from Tablet Mode. To save your current project (.vue or .zvf) file to a different filename or folder location, use Export. For more information, see Export (Tablet Mode).

  • Enhanced attachment workflows

    • Smart Review automatically creates an attachments database for projects to make attaching documents a faster workflow. When exporting projects, Smart Review copies the attachments database. By default, Smart Review provides the [project name]-Attachments.mdb file with your project.

    • Smart Review has improved the way to attach associated, external 2D drawings to 3D model objects:

      • You can attach 2D drawings to specific graphics objects by their linkage values using Tools > Get External Data > Edit Attachments. Linkages allow you to set up a one-to-one mapping between an object in the Main view and one or more documents. For more information, see Add and Edit Attachments.

      • A new Auto-Attach command allows you to attach Smart 3D (.sha and .pid) drawings to 3D objects in a model file. For more information, see Auto-Attach Smart 3D Drawings.

      • A new Auto-Attach Correlator utility is an administrative tool that runs in parallel with Smart Review for correlating and attaching Smart 3D (.sha and .pid) drawing object IDs to 3D object IDs in a model file. The utility allows you to maximize review time because you can run it interactively or via a command-line. This eliminates the manual process of attaching 2D drawings individually. For more information, see Auto-Attach Correlator Utility.

      • The new Select Correlations command, available in both Tablet and Classic modes, automatically selects all the correlated 2D and 3D objects in the Main view and Document view. This feature allows you to see which parts of the model (if any) are correlated, and then further investigate objects with X-Ray, Clipping, and Isolate commands. For more information, see Select Correlated Smart 3D Objects.

      • The Text view (Window > Text) now displays correlation results. For more information, see Select Correlated Smart 3D Objects and Text Command.

  • Server connection for the latest data updates

    • View current 2D drawings from Smart 3D. You can now connect from Smart Review to a Smart 3D server to view 2D drawings associated to 3D objects in a model. You can then use Copy Documents Locally to download and attach the drawing to the object so that you do not have to stay connected for your review work session. For more information, see Access 2D Drawings and Copy 2D Drawing Documents.

    • View current properties and 2D drawings from documents in a SmartPlant Foundation (SPF) or HxGN SDx Operations server. You can export a project file in an SPF or SDx Operations session to a .zvf file. Smart Review saves the server connection information for automatic server connection the next time you open the exported project .zvf file. The new Export command replaces the Save As command in Classic mode and the Save command in Tablet mode. For more information, see Export (Tablet Mode), Export > Project, and Export and Connect to SPF/SDx Operations.

    • A custom URL protocol Smart Review Launcher has been added to the API so that you can open and control Smart Review using hyperlink URLs, without using the Create Project dialog box. Any time you issue a URL command through the API, notifications display in the Windows 10 Action Center. For more information, refer to the "Smart Review URL Launcher" section in the Intergraph Smart® Review DRAPIX Programmer’s Guide.

  • Tablet mode additions and enhancements

    • Touch navigation has been updated for Tablet mode operations and new navigation controls have been added. For more information, see Navigation (Tablet Mode).

    • A new Clip control has been added to the Clip command in Tablet mode. This new control provides an easier way to access clipping features and provides a more focused clipping workflow. For more information, see Clip (Tablet Mode).

    • The focus point for zoom and rotate object operations now stays within the anchor point between the two fingertips. For more information, see Navigation (Tablet Mode).

    • You can now double-tap to enter a multiple selection mode to quickly select objects in the view.

    • A list of search results now displays from which you can select one or more matching objects. For more information, see Search (Tablet Mode).

    • A filter has been added that allows you to narrow your object search by project files. For more information, see Search (Tablet Mode).

Reflective phong shading to elevate model display

  • A Reflective Phong Shading mode has been added to Tablet and Classic modes. In Tablet mode, a Reflection option has been added to Settings and a Reflective Phong Shading mode has been added to the View > Display menu. For more information, see Define Settings and Server Connections and Reflective Phong Shading Command.

  • The Display tab in the View Settings dialog box now contains a menu list to select modes: Full Shading, Phong shading, Reflective Phong, and Wireframe. This change is also in the Display tab in the Save and Recall Views > Edit View dialog box so that key frame animations can take advantage of the new reflectivity rendering.

  • The Performance Control has been updated to include each of the shading modes. For more information on setting the Performance Control, see Set Motion and Display Performance.

  • When you select the Environment box in the View > Settings > Photo-Realism Settings, objects with reflectivity material assignments reflect the images making up the environment. For more information, see Environment Tab (Photo-Realism Settings Dialog Box).

  • In addition to the Reflective Phong Shading command, the View > Display menu now contains the Full Shading and Phong Shading commands, which can be used in conjunction with Outline and Wireframe commands. This functionality replaces the Shade with Outline and Wireframe with Outline commands. For more information, see Phong Shading Command, Outline Command, and Wireframe Command.