P&ID File Viewer - Intergraph Smart 3D - Administration

Intergraph Smart 3D Integration

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Administration
Version_S3D
12.x(2018)

Displays the P&ID you selected. This window is associated with the SmartPlant > View P&ID command.

Toolbar

Zoom Out

Decreases the display size of selected objects.

Zoom Area

Magnifies an area of the model. Drag or click two points to create a fence around an object or area of the model that you want to enlarge.

Fit

Fits all visible objects in the active view.

Pan

Moves the view up, down, left, or right to display other areas of the model. The pointer appears as a hand when this command is active.

Show Primary View

Displays the primary components only for the P&ID.

Show Typicals View

Displays the typicals components only for the P&ID.

Show Primary and Typicals

Displays both the primary and typicals components only for the P&ID.

View Menu

This menu contains the Fit, Zoom In, Zoom Out, Zoom Area, and Pan commands to assist in orienting the P&ID view.

Tools Menu

Magnify

Displays a small zoomed-in view of a portion of the P&ID.

Overview

Displays a small view of the entire P&ID.

Select Correlated

Selects the 3D objects that are correlated to the design basis objects. The selection of objects is based on the locate filter that is currently specified. The Select Correlated command highlights the correlated objects in the model and provides a way to quickly see areas where you need to do more work, such as highlighting all objects that have Data - mismatch.

Some of these objects may not have corresponding objects on the P&ID (for example, the pipeline object). These commands also select objects regardless of whether the objects are loaded in the current workspace or not. It will not change the workspace definition. These objects can then be manipulated by commands. If they do not match the workspace filter, then they will be removed from the workspace on the next workspace refresh.

The Select Correlated command includes the following options: Correlated - data match, Correlated - data mismatch, Correlated - topology mismatch, Correlated - that are in as-built, Approved - topology mismatch, and Approved - all mismatches. For more information about the first three options, see Set Correlation Status Colors Dialog Box. The Correlated - that are in as-built option selects objects in the 3D model that are related to as-built and also are on the currently active P&ID.

Options Menu

Set Correlation Status Colors

Specifies the colors of various objects in the P&ID. The colors reflect the correlation status between P&ID objects and the corresponding objects in the 3D model.

Set Highlight Color

Sets the color of highlighted objects on the P&ID Viewer.

Set Select Set Color

Sets the color of selected objects on the P&ID Viewer.

Layer Controls Menu

Show Typicals

Displays the typicals components in the P&ID File Viewer.

Hide Primary

Removes the primary components from the P&ID File Viewer. This command appears if the Show Primary command is selected.

Swap on Highlight

Displays either the primary or typicals components when a correlated 3D object is selected in the model. For example, if the typicals components are hidden and you select a 3D object that is correlated to a typicals object, then the typicals components are displayed and the primary components are removed from the view.

See Also

Display a P&ID and Retrieve Drawing Data