Select - Intergraph Smart 3D - Help

Intergraph Smart 3D Common

PPMProduct
Intergraph Smart 3D
PPMCategory_custom
Help
Version_SThreeD_Custom
10.1 (2014 R1)

Locates one or more objects to apply a specific command. When you choose the Select command, the ribbon displays the default filter for the task and the Inside and Inside/Overlapping fence commands. The fence commands allow you to select groups of objects by drawing a dashed rectangle around them. The selectable objects are based on your existing permissions, as well as the available locate filters in that task. After you select an object or group of objects, the software replaces the selection ribbon with an edit ribbon for the select set.

Locate Filter

Specifies a filter for the selection of specific object types. Filters allow you to select specific types of objects, or all objects. Filter options are unique for each task. Unlike the user-defined filters that you create through the Define Workspace command, the locate filter options are defined by the software.

Inside

Specifies that all objects located entirely inside the fence be selected. This setting is the default for the Select command.

Inside/Overlapping

Specifies that all objects located entirely inside the fence and those outside the fence but touching the fence at some point are selected.

Cancelling Multi-Step Commands

You can use the Select command to cancel another command. For example, if you are involved in a multiple step operation such as routing a pipe, you can click the Select command to quit the Route Pipe command. Optionally, you can also press ESC or right-click to return to the Select command.

Using Filters

When you click the Select command, the Locate Filter box displays the active filter for your task, and each task provides a unique list of available filter options. You can use these filters to:

  • Control the selection of compound (or owner) objects versus selection of the constituent components. For example, in the Piping task, you have the option to locate the run, the parts, or the features of the run.

  • Filter on any object in the current task.

You can apply locate filters to the highlighting and selection in both the graphic and Workspace Explorer views. You can also use the Edit > Locate Filter command to change the locate filter when you are in the middle of a command, without canceling the command.

Selecting Graphically

Regardless of the filter you use, you can select objects using the Fence Inside Only or Fence Inside Overlap commands, or you can add objects to or remove objects from the select set by pressing CTRL or SHIFT and then selecting the object.

If you are in the SmartStep of a command, you do not need to press CTRL or SHIFT to multi-select.

When you pass the cursor over objects in the workspace, they highlight in a predefined color. When you select an object, the color changes to show that the object has been selected. You can change the colors used to distinguish highlighted and selected objects on the Colors tab of the Tools > Options dialog box.

After you select one or more objects, the Select ribbon is replaced by another ribbon. If you are in the appropriate task to edit the selected objects, a ribbon specific to that task displays. Otherwise, the new ribbon contains only a Name box and a System list. The specific edit ribbon that appears for each object varies from one task to another. In other words, the ribbon that appears when you select a segment of pipe in the Piping task contains different lists and boxes than when you select a member in the Structure task.

  • If you select an object that has been deleted from the database or is not in the database, the software displays a message that the object cannot be found. Click File > Refresh Workspace to update the session.

  • In addition to graphical selection, you can also select objects by clicking their names in the Workspace Explorer, or use Tools > Select by Filter to create a filter to select objects.

  • You can select and delete an object from any task, as long as you have the necessary security permissions to make that change.

Using QuickPick

When the cursor moves over an area that contains multiple objects, the cursor changes to the QuickPick icon .

Single mouse click when is displayed to activate QuickPick and help you select a specific object. QuickPick displays as a list box near your cursor location.

The QuickPick list displays the located model objects. Scroll your mouse wheel, or use the keyboard arrow keys, to highlight the corresponding object in the graphic view. If the software locates any nested geometric elements, it displays the icon. Click your mouse wheel to display the secondary list of the nested geometric elements.

Click your mouse wheel again to select the highlighted item from the QuickPick list.

  • Press ESC or move your cursor away from the list to exit QuickPick without making a selection.

  • You can specify the number of seconds the pointer must rest on an object before the QuickPick feature is available. For more information, see Set the activation time for QuickPick.

What do you want to do?