Update database locations when a server changes - Intergraph Smart 3D - Administration

Intergraph Smart 3D Project Management

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Administration
SPFVersion_custom
2019 (10.0)
Version_S3D
12.1(2019)

Use this procedure to update server locations for your databases when the database files have moved to a different server.

  1. In the tree view of the Project Management task, select a model that has one or more missing databases.

    The icon of a missing database displays as a red question mark in the tree view, such as a model or a catalog .

  2. Click Edit > Properties.

    The Model Properties dialog box displays.

  3. Click the Databases tab.

    Missing databases display the Server cell as white (active) on the grid. In the following example, the catalog and reports databases (along with their respective schemas) are missing.

  4. For each missing database, select the appropriate server from the Server list.

    If the software finds the database on the selected server, the updated server name changes to grey and inactive.

    If the software cannot find a database on the selected server, a message box displays.

  5. Click OK to return to Project Management.

    The tree view refreshes, and the database icons display without the red question mark, such as a model or a catalog .

  • Although the software alerts you to missing databases, it is unable to determine why a database cannot be found on the specified server.

  • In situations where the software is unable to relocate the named database on the server you specify in the Server list, you must use Restore on the Tools menu.

  • When multiple models use one catalog, correcting the server information of a moved catalog or catalog schema database corrects the location for every model.

  • The software automatically regenerates the reports databases if you relocate the catalog, catalog schema, or model database. In situations where you must relocate the reports databases, use Edit > Regenerate Reports Database to regenerate the reports databases.

  • Additional SQL settings can be required when relocating databases on linked servers. Contact your system administrator.