Import Pipe Support Legacy From Data File - CADWorx - Help

CADWorx Spec Editor

PPMProduct
CADWorx
PPMCategory_custom
Help
Version_CADWorx
20.1 (2020 R1)

CADWorx Spec Editor Home tab: Legacy Catalog Data > Pipe Support Import Data

Catalog Data: Right-click the catalog > Import Pipe Support Legacy From Data File

Imports legacy pipe support data from a data file.

Add Files

Imports legacy data using chosen files.

Add Folder

Imports legacy data using chosen folders.

Delete

Deletes a selected source from the Source Files box.

Source Files

Specifies the selected files or folders for import.

Converted Files

Specifies the files converted after import.

Size Table

Specifies the size table for validation of import.

Select Data File Type

Specifies the component type for the specification import.

Import

Imports the legacy data.

View Log File

Displays the log file for the legacy import.

There are two options for importing data from the data files. Depending on which kind of data you want to import, use Add Files or Add Folder.

Import using Add Files

  1. Click the Home tab, and then click Pipe Support Import Data on the Legacy Catalog Data panel. Alternatively, click in Catalog Data, right-click the catalog, and then select Import Pipe Support Legacy From Data File.

    The Import Pipe Support Legacy From Data File dialog box displays.

  2. Click Add Files .

    The Open dialog box displays.

  3. Select a legacy file to import, and then click Open.

    The file displays in the Source Files box.

  4. Select a source file, and then under Validation, select a size table from the Size Table list.

    The data file type displays in the Select Data File Type box.

  5. Select a data file type from the Select Data File Type box.

    Only one data file type can be selected at a time. The data file type needs to be set for each source file listed in the Source Files box.

  6. Click Import.

    The converted file displays in the Converted Files box.

    These steps can be repeated without needing to close the dialog box.

  7. Click Close when finished.

  8. Click File > Save to save the changes to the catalog.

  • To see information about the data conversion, click View Log File.

  • You can double-click any of the data files in the Source Files dialog box to view its information in Notepad.

Import using Add Folders

  1. Click the Home tab, and then click Pipe Support Import File on the Legacy Catalog Data panel. Alternatively, click in Catalog Data, right-click the catalog, and then select Import Pipe Support Legacy From Data File.

    The Import Pipe Support Legacy From Data File dialog box displays.

  2. Click Add Folder .

    The Browse For Folder dialog box displays.

  3. Select a legacy folder to import, and then click Open.

    The entire folder displays in the Source Files box.

  4. Select a source file, and then under Validation, select a size table from the Size Table list.

    The data file type displays in the Select Data File Type box.

  5. Select a data file type from the Select Data File Type box.

    Only one data file type can be selected at a time. The data file type needs to be set for each source file listed in the source files box.

  6. Click Import.

    The converted file displays in the Converted Files box.

    These steps can be repeated without having to close the dialog box.

  7. Click Close when finished.

  8. Click File > Save to save the changes to the catalog.

  • To see why something was not converted, or what, where, and when it was converted, click View Log File.

  • You can double-click any of the data files in the Source Files dialog box to view its information in Notepad.