Add new user shape - CADWorx - Help

CADWorx Spec Editor

PPMProduct
CADWorx
PPMCategory_custom
Help
Version_CADWorx
20.1 (2020 R1)

Adds a user shape to the specification.

If Spec Editor is already displayed skip to step 2.

  1. Click Start Spec Editor on the spec view palette. Alternatively, click Spec Editor on the desktop.

    The Specification Editor software opens.

  2. Click File > Open.

    The Open File dialog box displays.

  3. Select a catalog, and then click Open.

    The Catalog Data window displays.

  4. Click the (+) sign on the Data Tables folder.

    The Data Tables list displays.

  5. If your Data Table List Mode is set to Category List Mode, then right-click User Shapes, and select Add Data Table .

    The New User Shape Table displays.

    OR

    If your Data Table List Mode is set to Group List Mode, then right-click a group folder, and select Add User Shape Table.

    The software places the user shape in the group folder that you select.

    The New User Shape Table displays.

  6. Type the name of the table in the Name box.

  7. Select a user type in the Type list, or User Shape Number in the Number list.

  8. Select a size table in the Size Table list.

    You can select and clear multiple sizes by clicking the Size Table ellipsis.

  9. Type the part number in the Part Number box.

  10. Type the user shape folder name in the Usershape Folder box.

  11. Select the Reducing Component check box if you want this to be a reducing component.

  12. Select a Bill of Material type from the BOM Type list.

  13. Select a layer from the Layer Name list.

  14. Select a color from the Color Index list.

  15. Type a Sort Sequence.

  16. Type an Isogen Identifier.

  17. Select an SKEY from the Isogen SKEY list.

  18. Select the Optional Component check box if you want to make this user shape optional.

  19. Type the description of the user shape in the Description box.

  20. Click OK.

    The user shape file displays under the User Shape category in Catalog Data when your Data Table List Mode is set to Category List Mode.

    OR

    The user shape file displays under the selected group folder in the Catalog Data when your Data Table List Mode is set to Group List Mode.

Click File > Save to save the changes to the catalog.

See Also

Add MAINSIZE

Add New MAINSIZE