Sketch 2D Best Practices - Intergraph Smart 3D - Help

Intergraph Smart 3D Molded Forms

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Help
Version_S3D
10.1(2014R1)

The Sketch 2D option is used in several commands to create sketched boundaries, openings, curves for extruded plate systems, and profile and seam landing curves. The following Sketch 2D best practices help you create objects in Molded Forms that you detail in the Structural Detailing task and manufacture in the Structural Manufacturing task.

Templates

Sketch 2D default display options are saved in the file [Product Folder]\Common2D\Symbol2D\Templates\template.sha. You can change the default display by changing options in this file:

  1. Right-click template.sha and select Properties.

  2. Clear Read-only and click OK.

  3. Open template.sha and change any of the following default display options:

    • File > Properties. You can change the units displayed in command ribbon bars on the Units tab.

    • View > Toolbars. You can select the toolbars that are displayed.

    • Format > Dimensions. You can change the units used in dimensions, the text size, and other dimension properties.

    • Tools > Options. You can change the default colors on the Colors tab.

    • Tools > Display Manager. You can change the default geometry color, line type, and width for individual layers.

    • Tools > SmartSketch Settings. You can select the SmartSketch relationships that are enabled on the Relationships tab.

  4. Save and close the file.

Fractional Units

The default units and precision values in Sketch 2D are defined in a 3D task. For example, if the file [Product Folder]\Common2D\Symbol2D\Templates\template.sha has default units set to mm, and the units of measure in Molded Forms are set to ft-in, Sketch 2D defines the units of measurement as ft-in.

The Properties dialog box in Sketch 2D allows you to view the defined units of measurement and to specify the fractional precision value. If you need to use a specific fractional precision value for all tasks in Sketch 2D, you can specify the precision value in the template file, which takes precedence over the precision value defined by the 3D task.

The following example shows how to modify the length readout precision to 1/64 in the template file:

  1. In the template.sha file, set the precision value to 1/64, and save the file.

  2. In the Molded Forms task, click Tools > Options.

    The Options dialog box displays.

  3. Under Units of Measure, set the distance readout to ft-in (fractional).

  4. Click OK.

    The distance units in Sketch 2D are now in ft-in with a precision value of 1/64.

Number of sketch files allowed per plate

Sketch 2D geometry for an object is saved in 2D files cached in the model and related to the object.

The Boundary Curve step for the plate system commands uses one 2D file. All boundary curves are in one 2D file for each plate system, and are modified, added, or deleted in the same file.

The Place Opening , Stiffener Profile System by 2D Projection , and Design Seam by 2D Sketch commands can each have:

  • Multiple 2D files, with a separate file for each object on one plate system. The objects are modified in the 2D file, and deleted from the graphic view or Workspace Explorer.

  • Geometry for multiple objects in one 2D file. The objects are modified or deleted in the 2D file.

  • One 2D file that applies to multiple plate systems. Changes to the 2D file are reflected on all plate systems.

  • A combination of these files.

Add items to sketch

The Add Intersecting Item and Add Projection Item steps are used to add reference structure to Sketch 2D. Select the minimum number of needed items.

More than 30 items added to a sketch file can slow down software performance when the object is recomputed.

Next, you can select Auto to automatically add all objects that are relative to the object to be sketched to the current select set. Items that pass the criteria are added to the select set and are highlighted in the graphic view, as well as the Workspace Explorer.

The filter criteria that the software uses to determine eligible candidates depend upon whether Add Intersecting Item or Add Projection Item was selected in a previous step. The following table lists the various relevant objects that are automatically imported based on the target, or base sketch, object type.

Base Sketch Object

Intersecting Objects

Projecting Objects

Plate System

  • Stiffeners

  • Edge Reinforcements

  • Seams

  • Bounded Objects

  • Bounding Objects

  • Knuckle Reference Curves

  • Reference Curves

  • Stiffeners

  • Penetration Plates

Plate Part

None supported in the current version of the software

None supported in the current version of the software

Profile System

None supported in the current version of the software

None supported in the current version of the software

Member

None supported in the current version of the software

None supported in the current version of the software

Designed Member (Built Up)

Same as Plate System

Same as Plate System

If no objects are added to the select set, the software displays a message on the status bar.

If you clear Auto, all selected objects, whether added to the select set automatically or manually, are cleared. Selecting Auto adds back those objects that initially passed the filter criteria, but it does not add back any objects that you selected manually.

When the selected plate system is large, Auto automatically adds all objects relative to the sketch in the context of intersecting or project. This can slow down software performance.

Layers

The software automatically defines several layers in Sketch 2D. Reference items (selected automatically by the software or manually using the Add Intersecting Item and Add Projection Item steps) are placed on those layers:

  • Default Layer

    The software only uses geometry that you create on the Default layer. You can put other geometry, such as construction lines, on other layers. The Default layer must be the first layer alphabetically. To avoid a conflict, you should add a "z" prefix to any layer which you add, such as "z_construction."

  • Infinite Elements Layer

    Contains reference items with infinite geometry intersecting the sketch plane, such as grid planes. Objects on this layer can be used with dimensions and relationships.

  • Inputs Layer

    Contains other reference items intersecting the sketch plane that can also be used with dimensions and relationships. The reference geometry includes openings, design seams, plate systems, and profile systems.

  • No_Constrained_Elements Layer

    Contains reference items that do not intersect the sketch plane. Also contains reference items that cannot be used with relationships and dimensions, such as plate and profile parts. By default, you cannot select reference geometry on the No_Constrained_Elements layer. To make the geometry selectable, you must make No_Constrained_Elements the active layer, and then switch back to the Default layer.

You can add relationships and dimensions to reference geometry on the No_Constrained_Elements layer, but the relationships are not saved when you click Finish.

You can quickly turn layers on or off by right-clicking and then selecting the layers to display from the context menu. Smart 3D displays a check mark next to the layers that are displayed. The active layer must display, so you cannot turn that layer off.

Multiple reference planes

You can add reference planes to Sketch 2D that are different than the sketching plane, but parallel to the sketching plane. This is useful in defining landing curves for projected profiles and seams on the hull. Use Add Projection Item to add the reference planes.

The additional reference plane intersection geometry is gray in color and placed on the No_Constrained_Elements layer.

Using SmartSketch Drawing Editor to save sketch geometry

SmartSketch Drawing Editor, delivered to [Product Folder]\Shape2D\Bin\shape2dserver.exe, can be used to save geometry commonly used in Sketch 2D, such as:

  • Mother curves and extrusion curves for extruded plate systems.

  • Boundary curves.

  • Openings or sketched features not included in the Catalog.

  • Landing curves for projected profiles and seams.

You can copy the geometry from Sketch 2D and paste it into SmartSketch Drawing Editor, or create the geometry directly in SmartSketch Drawing Editor. Geometry can be saved in multiple SmartSketch Drawing Editor files or into a single file with multiple sheets. The geometry can be copied from SmartSketch Drawing Editor and pasted into Sketch 2D as needed.

Deleting reference geometry

You can delete reference geometry from the sketch when the software includes geometry that you do not want to see. The reference structure is not deleted, and the reference geometry is recreated the next time that you open the sketch.

Modifying groups of geometry

The software automatically groups Sketch 2D geometry when you click Finish. When you modify the existing 2D geometry of an object, you must maintain the original group identifier by using the following methods:

  1. To modify or delete existing geometry, use QuickPick, Top Down or Bottom Up with Select Tool to select the geometry instead of the group.

  2. To add new geometry to a group, use Edit > Group Modify.

  3. To replace all geometry in a group with geometry copied to the clipboard, use Replace Group Elements .

Rectangles

Use Line or Line/Arc Continuous to create rectangles.

If you use Rectangle , you must select Tools > Maintain Relationships. Right-click the geometry, and then select Convert. This converts the rectangle into four lines and the correct connection relationships are created at the corners.

Constraints

Use relationships and dimensions to constrain geometry to reference structure. This keeps the geometry properly related to the reference structure if the reference structure changes.

Keep relationships and dimensions as simple as possible. This allows the geometry the best chance to update if the reference structure changes.

Connections

Connection relationships are required for the software to create connected geometry.

Do not create a connection between the corner of the sketched geometry, and the corner of the bounding object. Instead, move the constraint slightly off the corner.

Good: All endpoints of opening are connected.

Bad: Missing connection at one corner causes the creation of the opening to fail.

Good: All endpoints of extrusion curve are connected.

Bad: Missing connection on extrusion curve.

Plate system is missing part of the curve.

Extending sketch geometry to intersect bounding structure

Extend sketch geometry beyond bounding reference structure geometry to ensure that the sketch geometry intersects the reference structure at all locations.

Good:

Extrusion curve extends beyond the hull.

Bracket boundary curve extends beyond the top flange and the bottom of the bottom flange.

Bad:

Overlapping sketch geometry for boundary curves

A boundary curve with all geometry connected is treated as one edge in the Graphics View. You may sometimes want parts of the curve to be treated as separate edges at sharp discontinuities such as corners. This allows you to add edge reinforcements in the Molded Forms task or edge treatments in the Structural Detailing task to part of the boundary curve without defining additional boundaries. In order to separate the boundary curve into separate edges, overlap the boundary curve geometry instead of connecting it at the corners:

Creating boundary curves on the thickness side of a plate

If your plate boundaries include a plate system with the thickness direction towards the plate that you are creating, a profile mounted to the bounding plate system and a sketched boundary, and then the boundary curve must intersect both the profile system and profile part.

In the following example:

  • The solid blue line is the molded surface of the bounding plate system.

  • The dashed blue line is the thickness direction for the bounding plate part.

  • The dashed gray profile outline is the bounding profile system mounted to the bounding plate system at the molded surface (on the No_Constrained_Elements layer).

  • The dashed blue profile outline is the bounding profile part mounted to the thickened bounding plate part.

  • The solid black line is the intended boundary curve intersecting the profile part.

  • The solid red line is the required adjustment to the boundary curve, passing through both the profile part and profile system, and intersecting the profile system.

The black line is the intended boundary curve. It can be constrained to the dashed blue profile part using relationships and dimensions. The red lines are additional geometry that must connect to the black boundary curve, pass through the profile part geometry, and intersect the dashed grey profile system geometry.

Arcs in boundary curves

If a boundary curve ends with a circular or elliptical arc, you must add a line segment pointing away from the direction of the arc. This prevents the arc from extending back onto the boundary curve as the curve is calculated.

In the following example, the black curves are the intended boundary curve. The red line is the extension to the boundary curve that prevents the arc from extending back onto the boundary curve.

Multiple curves

Do not create a close boundary curve contour that overlaps trimming input geometry. Instead, draw two separate curves. In the following example, there are two separate curves, one for corner feature and one for diagonal boundary.

1 - Corner feature curve

2 - Diagonal boundary curve

Associative offsets

The Associative Offset command allows you to create a curve based on an existing curve, and place the new curve at a specified offset. To use this command, you must add it to a toolbar.

  1. Right-click an existing toolbar, and click Toolbars.

  2. Click Customize on the Toolbars dialog box.

  3. Click Manipulation on the Categories list.

  4. Drag the Associative Offset icon from the Buttons list to an existing toolbar.

For more information on the Associative Offset command see the Associative Offset Command topics in the SmartSketch Drawing Editor help file.