Run Report - Intergraph Smart 3D - Administration

Intergraph Smart 3D Project Management

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Administration
Version_S3D
12.x(2018)

Tools > Run Report runs an existing catalog or personal report. By default, all reports generated with this command are in Excel format (.xls). However, you can customize .xml files to report in other formats. You can review each completed report with Excel.

You can also use Tools > Run Report in any Smart 3D task to generate reports.

Reports are divided into two overall categories: catalog reports and personal reports. Catalog reports include report templates delivered with the software and templates created by a reports designer. Personal reports use templates you create and save.

Depending on the report definition, you may need to specify additional information such as filters or parameters when running a report. Here are some examples.

If a required filter does not exist, the software displays a message asking you to create the required catalog filter. When you provide the necessary information, the command displays the report in Excel.

  • If any errors occur during the processing of a report, the command generates an error log called SP3DReports.log in your local Temp folder.

  • Reports can have a maximum of 65,536 rows. If a report reaches the maximum, printing stops. The log file message alerts you about the limit.

  • You must enable Trust access to the VBA project object model in Excel. For more information, see Enable or disable macros in Office files in Excel Help.

  • For information about creating report databases, see the Intergraph Smart 3D Installation Guide available from Help > Printable Guides.

Run Report Dialog Box

What do you want to do?