Custom Commands - Intergraph Smart 3D - Help

Intergraph Smart 3D Common

PPMProductFamily
3D Design and Visualization
PPMProduct
Intergraph Smart 3D
PPMCategory
Help
Version_S3D
11.x(2016)

Provides end-user application programming capability for the 3D software. Using Microsoft® Visual Basic, you can create a custom command that groups a series of commands and instructions into a single command that runs as an operation in the 3D software. As a result, you can access the customized commands that directly relate to the work routine in your operation.

Use the Visual Basic Command Wizard to help you build a custom command. For example, the wizard's first step prompts you to identify general information including command name, project name, author, and company. Start the wizard in Visual Basic by clicking Command Wizard on the Add-Ins menu. For more information about installing the Command Wizard and other programming resources, see the Intergraph Smart 3D Installation Guide, available by clicking Help > Printable Guides in the software.

After adding a custom command in the 3D software, you can edit it using the Edit Custom Command dialog box which requires you to specify the program identifier (prog_id), command name and description, command priority, and a command line of arguments in a string.

Delivered Custom Commands

The following list provides descriptions and ProgIDs for the delivered custom commands. For more information consult the Database Integrity (DBI) Guide and the Common User's Guide (Tools Menu > Custom Commands). Both are available from Help > Printable Guides.

Custom Command

Check Database Integrity

ProgID

SP3DCheckDatabaseIntegrity.CCheckObj

Description

Creates records for the objects that need to be cleaned. Run this custom command directly on a database (site, catalog, or model). Then, you can generate a report to review the errors that the Check Database Integrity command generated.

For more information on this command, see the Database Integrity Guide.

Custom Command

Clean Database

ProgID

SP3DCleanDatabaseCmd.CCheckObj

Description

Deletes or cleans an object. Use this command when an action on the Check Database Integrity report is To Be Removed or To Be Repaired.

For more information on deleting and cleaning objects in the database, see the Database Integrity Guide.

Custom Command

Create Drawing View

ProgID

MenuDrawView.CMenuDrawView

Description

Saves and converts the contents of a three-dimensional graphic view window into a snapshot view. This command creates a rectangular object associated to a clipping volume, or volumes, in the three-dimensional model.

Before you create a snapshot view using this command, you must have added at least one composed drawing type to the Management Console in the Drawings and Reports task.

You can save additional views by updating the view contents and then saving the new design. If you used the Tools > Hide command to avoid displaying certain objects, those objects are included in a composed drawing you create.

To use the Tools > Snapshot View command, you must have appropriate permissions to access composed drawing types. If you have only read permission, you receive a message that alerts you to this condition.

After you create the snapshot views, you can add them to composed drawings when you use the Tools > Drawings Console command.

Custom Command

Duplicate Part Numbers

ProgID

DuplicatePartNumbers,Ingr.SP3D.ProjectMgmt.Client.Commands.DuplicatePartNumbersCommand

Description

Repairs duplicate parts that exist in the catalog, including any proxies that might also exist in all the associated models. The command is available only when you have selected a catalog in the Project Management tree.

In a Global Workshare environment, you must run this command only from the host location.

Custom Command

Find Object by OID

ProgID

SP3DFindObjectByReport.FindObjects

Description

Finds objects with integrity problems in a graphic view. Before running this command, you must define your workspace to include these objects. Run a database integrity report, and use the reported OIDs of the objects in the workspace definition.

For more information on this command, see the Database Integrity Guide.

Custom Command

Fix Project Root

ProgID

SP3DPRJMGTRepairCmd.FixCnfgProjectRoot

Description

Synchronizes the model name in the model database and the site database. The name in the site database prevails.

You must run this command from a task in the model, not from Project Management.

Custom Command

Large Sector Utility

ProgID

DwgBinaryEditorCmd.FixSectorSize

Description

Converts existing production drawings from a small to a larger sector format to avoid exceeding Microsoft structured storage limits and causing errors to occur.

Custom Command

Model Data Reuse (MDR) Validation Tool

ProgID

MDRValidation.CValidateGeometry

Description

Helps you in analyzing the MDR results. If MDR is performed across models, you must run this tool on both the source and the destination models to enable analysis of the results. The tool locates the objects in the model that failed to copy as well as the objects that have a data mismatch with the source and the destination. Information for this tool is provided in the Project Management User's Guide.

Custom Command

Modify Style

ProgID

ModifyStyleCmd.ModifyStyles

Description

Modifies system-based styles existing in a custom model database. For information on creating correct style colors, see Format Style.

For older databases (created before version 06.00.22xx), run this custom command to update the database; then exit the application. Delete the old session file and open with a new session file. The new colors are available.

New databases (created after version 06.00.22xx) automatically use the corrected colors.

Custom Command

Place Piles

ProgID

PileFoundation,PileFoundation.PileFoundation

Description

Provides a placement wizard to facilitate the modeling of pile members. Through the Place Piles command, you can specify the number of piles in each direction as well as edge clearances and depth dimensions. You can also specify the member cross section and material for the piles.

Custom Command

Placing Supports from XLS

ProgID

PlacingSupportsFromXLS,PlacingSupportsFromXLS.PlacingSupportsFromXLS

Description

Places support information from an .xls file into Smart 3D. You must run this command from Smart 3D, and not from Project Management. For more information, see Placing Supports from XLS Command in the Smart 3D Hangers and Supports User's Guide.

Custom Command

Remove Design Basis

ProgID

IMSEngFrameworkCmd.RemoveDsgnBasis

Description

Removes all correlation relationships and then deletes all design basis objects in the 3D model.

This command is useful when you want to register to a different SmartPlant foundation database.

After running this command, you must register the model, retrieve information, and correlate the objects again.

You must run this command from a task in the model, and not from Project Management.

Custom Command

Repair Documents

ProgID

DwgRepairCmd.RepairDocuments

Description

Updates invalid Styles.sha or Symbol Browser file paths on a document or a set of documents. Invalid file paths can occur when you change the symbol share. This causes overhead while editing, saving, or updating documents.

Custom Command

Repair Duplicate Permission Group ID

ProgID

RepairDuplicatePermissionGrpID,Ingr.SP3D.ProjectMgmt.Client.Commands.
RepairDuplicatePermissionGrpIDCommand

Description

Lists all catalogs and models that have a duplicate permission group ID.

Select the catalogs and models to repair. You cannot select all of the databases under a particular duplicate permission group ID.

This command can only be invoked from Project Management.

This command cannot be run from a satellite location. You should run this command only from the host location.

Custom Command

Repair Permission Groups

ProgID

PermissionGroupsAndLocations,Ingr.SP3D.ProjectMgmt.Client.Commands.PermissionGroupsAndLocationsCommand

Description

Repairs the corrupted relationship between permission groups and the location for both catalog and model permission groups.

If a permission group has lost the relationship with a location or has multiple relationships, then this command re-establishes a proper relation. This command cannot be run from a satellite location. You should run this command only from the host location.

Users with full permissions in the corrupted permission group can only re-establish the relationship.

Custom Command

Repair Style Path

ProgID

DwgRepairCmd.RepairDocuments

Description

Fixes Symbol and Style paths on RAD documents.

Custom Command

Synchronize Drawing Component Templates

ProgID

DwgSynchTemplatesCmd.SynchTemplates

Description

Repairs a drawing component that has become corrupted by synchronizing it with a different, uncorrupted drawing component. This command requires that the source component is the same type as the corrupted component, and that the source component cannot be corrupted. Also, the number of views on the source component must be the same as the number of views on the corrupted component. The names of the views on the source component must match the view names of the corrupted component.

Custom Command

Synchronize Drawing Templates

ProgID

DwgSynchTemplatesCmd.SynchTemplates

Description

Synchronizes, or copies, a template from one drawing component to another.

Custom Command

Verify P&ID Integrity

ProgID

SP3DDisplayPIDService.VerifyPIDCmd

Description

Validates the internal connections between objects on a P&ID and objects in the model database. This command is useful when there is a problem displaying a P&ID or selecting objects on a P&ID. The command provides some basic troubleshooting statistics: number of design basis objects, number of 3D objects (correlated), number of P&ID objects, number of deleted P&ID OIDs, and number of duplicate OIDs.

Custom Command

Profile Auto Bound

ProgID

mhprofileautobound.AutoBoundProfile

Description

Creates mutual bounding between stiffeners profiles or profile edge reinforcements present on the chute plates. The command requires that the chute plates be mutually bounded to each other and that the distance between the stiffener\edge reinforcement is between 0 to 0.01m.

Custom Command

Audit Tool

ProgID

stAnalysisTool.AuditTool

Description

Compares two databases using an SQL query. The databases can be on different servers and have different catalog schema. Changed objects can be displayed in the workspace of the current model. This command is useful after performing a migration, synchronization, or hull swap.

Custom Command

GC Menu

ProgID

GCMenu.Activate

Description

Places the GC menu on the software toolbar. This menu contains commands for creating geometric constructions, GC sets, and GC macros. For more information, see Geometric Construction Macros (GC Menu) in the Molded Forms User's Guide.

Custom Command

Verify Seam Pattern to Split

ProgID

SplitCommands.VerifySeamPatternToSplit

Description

Checks the status of seams and plates split by the seams. This command provides a count of successful and failed splits, and modified, new, identical, and deleted leaf systems. You can also display the objects affected by the seams by selecting one or more of the following options: Identical Bodies (Green), Modified Bodies (Yellow), New Bodies (Red), Deleted Bodies (White), or Bad Splitters (Blue). This command is useful when swapping an old imported hull system with a new hull. For more information, see Swap Hulls on a Detailed Model Using Molded Forms Delay in the Molded Forms User's Guide.

What do you want to do?